Support » Plugin: MailPoet Newsletters (Previous) » Bad formatting on newsletter for some subscribers

  • My newsletter is being being received by some of our subscribers with poor formatting. Some subscribers are receiving the same newsletter exactly as I designed it:

    Here are some sample extracts of the poor formatting:
    ———————————————————
    <= tr>
    It is always nice = to see a couple of new faces.
    If you were unable to att= end, we do hope to see you at future meetings.
    • So that we can prepare t= he right amount of food
    • We can set out t= ables and chairs for the right amount of attendees
    •&n= bsp;To ensure that we have no exclusive members for your business sector
    ———————————————————

    There are random = signs appearing in the text.
    With the same newsletter being sent to 200 people, these characters aren’t there for all of the subscribers, just some of them.

    Are there any known remedies for this issue?

Viewing 9 replies - 1 through 9 (of 9 total)
  • Hi
    We are experiancing the same problem with mailpoet 2.7.7 on centos 6, apache 2.4 and php 5.3, 5.5 and 7.1

    The email is beeing sendt in multible formats / contenttypes
    Content-Type: text/plain
    Everything is ok

    Content-Type: text/html; charset=utf-8
    There seems to be a wordwrap at characterlenght 75 that breaks the line and introduces the =,newline problem.
    —————————————————————————-
    }.ExternalClass {width:100%;}.ExternalClass, .ExternalClass p, .Externa=
    lClass span, .ExternalClass font, .ExternalClass td, .ExternalClass div {li=
    ne-height: 100%;}#backgroundTable {margin:0; padding:0; width:100% !importa=
    —————————————————————————-
    in both the header and the content
    —————————————————————————-
     </span>  </p><p style=3D”font-family: Arial, ‘Helvetica Neu=
    e’, Helvetica, sans-serif;font-size: 13px;color: #000000;color: #000000 !im=
    portant;background-color: #FFFFFF;border: 0;letter-spacing: normal;mso-line=
    -height-rule: exactly;-mso-line-height-rule: exactly;line-height: 150%;marg=
    in-top: 1em;margin-right: 0;margin-bottom: 1em;margin-left: 0;padding-top: =
    0;padding-right: 0;padding-bottom: 0;padding-left: 0;vertical-align: top;wo=
    rd-wrap: break-word;”>Last but not least we want to draw your attention to =
    —————————————————————————-

    Somehow google mail ignores the characters, but outlook and others do not.
    I have not found any remedies, other than using a previus version.

    Plugin Author MailPoet

    (@wysija)

    We are already investigating what could be done on those situations, but the cause of this issue was the removal of our PHPMailer library in favor of using the one that already comes with WordPress, as requested by the WordPress.org repository admins. Unfortunately, we had no choice.

    You could always downgrade to version 2.7.6 where the emails are looking good: https://downloads.wordpress.org/plugin/wysija-newsletters.2.7.6.zip

    The same problem happens to me. Here is an example of bad formatting:

    <= !--[if gte mso 9]> = = = = = =
    = =
    =
    =
    =
    <= /table>
    = 
    Esc= ursione 19 Febbraio
    Domenica 19 Febbraio 2017/p>
    .....
    .....
    /div>
    <= td class="wysija_content_container center" style="border: 0;border-coll= apse: 
    


    Is there a way to revert to 2.7.6 without losing the settings?

    TIA

    I solved it using the following steps.

    1. Disable MailPoet 2.7.7
    2. Download, install and activate WP Rollback by WordImpress
    3. On the plugin page under the plugin MailPoet, click on Rollback
    4. On the screen that follows, rollback to 2.7.6
    5. Reactivate MailPoet

    All the settings and newsletters remained in tact for me.
    It does strongly recommend backing up during the process.

    Hope this helps

    thank you @culedude. I had the same problem before, your way of working did it for me! thank yu very much.

    I know this is an old thread, but I just noticed this same problem with 2.7.10. Is the solution the same: downgrade to 2.7.6? I’d hate to go back 4 versions…

    Here’s a sample of my poor formatting. What’s worse, the link to view this newsletter in your browser is also bad – it goes to the subscription confirmation page.

    ——————-
    <= tr style=”font-size:1px; mso-line-height-alt:0; mso-margin-top-alt:1px;”>=
    What’s in this email:

    • Giving m= y burdens to God
    • Photo Album

    • Things are happening!

    =
    give now.
    — = =
    Give it to Him and go to Slee=
    p
    Give it to Him and go to Sleep

    = =
    On the top of Mount Welirang
    <= td width=”100%” valign=”middle” class=”wysija_divider_container” styl= e=”height:1px;background-color: #ffffff;border: 0;padding-top: 15px;paddi= ng-right: 17px;padding-bottom: 15px;padding-left: 17px;” align=”left”> =

    ————————

    Yes, I still have the same problem. Resolved reverting to 2.7.6 🙁

    We’re still using V 2.7.6. because if the formatting problems and random characters. Was this issue ever addressed?

    boca jo

    (@boca-jo)

    It has never been addressed. I recently had 2.7.11.3 on a site and it was worse than ugly: some recipents’ providers like Outlook online were flagging the malformed mail as spam. As soon as I reverted to 2.7.6, the spam problem resolved.

    I hated to revert because a back-level MailPoet plugin got me in trouble a few years ago when they had a security hole. One of my sites got hacked because it was back level.

    Seriously considering MailChimp.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Bad formatting on newsletter for some subscribers’ is closed to new replies.