Support » Plugin: LiteSpeed Cache » Bad experience. Plugin has conflict with cloudflare

  • thanhstran98

    (@thanhstran98)


    I had a few terrible days.
    After I changed the mini CSS setting in this plugin setting and turned on the development mode of
    Cloudflare in ls cache settings. Cloudflare no longer caches my website,
    the number of requests and bandwidth to my origin server spiked. I reset the settings and the result is the same.
    in response header homepage :
    cache-control: no-cache, no-store, must-revalidate
    cf-cache-status: MISS

    I have added the code cache control to htaccess through this plugin.
    Although the cache-control in the header has changed to public, however, cf-status still MISS.

    I trying to delete all file created by Ls cache, all htaccess files, all cache, all data.
    Now in response header homepage:
    cache-control: max-age=0, no-cache, no-store, must-revalidate
    cf-cache-status: MISS

    I once again manually added the cache-control to the htaccess in pubic_html folder, but it can’t change anything. the cache-control in the header hasn’t changed to public anymore.
    I am sure you have left some code in the php file and are blocking the buffer from Cloudflare.

Viewing 1 replies (of 1 total)
  • Plugin Support LiteSpeed Lisa

    (@lclarke)

    I’m sorry to hear about your frustrating experience!

    Two things:
    1) CloudFlare’s development mode means that CF is temporarily turned OFF, so it is not going to behave as you expected. If you want CloudFlare to work, you should not enable development mode.

    2) We are always happy to help, if you are having difficulty with configuration. Please send email to support at litespeedtech dot com, and we can help you get everything set up properly.

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this review.