Support » Plugin: WP Deferred JavaScripts » Bad Bad Bad Bad Bad Bad Plugin !!

  • AboYousef

    (@aboyousef)


    This plugin killed my site!
    It completely destroyed my front page and stopped every java script !
    Even after uninstalling the plugin and deleting is permanently the site
    Is still brokrn !
    I want to remove all the effects of this bad, poorly designed plugin
    I need to get everything to normal, is there an author(s) for this
    thing !?

    https://wordpress.org/plugins/wp-deferred-javascripts/

Viewing 15 replies - 1 through 15 (of 21 total)
  • Plugin Author Daniel Roch

    (@confridin)

    The plugin only defers Javascript. It only works if all of your plugins and your theme are properrly enquing scripts. If one of them don’t, it may break your site : your other plugins and them have to enqueue script properly.

    If it breaks your site, you just have to deactivate WP Deferred JavaScripts. You may have to clear your cache :

    • Your browser cache
    • A plugin cache (WP Rocket, WP Super Cache, W3 Total Cache…)
    • A server cache, Varnish for example

    Regards,

    AboYousef

    (@aboyousef)

    I did deactivate it and completely removed it but still the jquery is not
    working which mean that my sliders, menu and call to action are dead!
    And of course I cleared my browser’s cache, my W3 cache and my cloud flare cache completely actually I cleared all of theme many times but the site is still broken!
    by the way while the plugin was still active i tried the exclude filter and
    it didn’t work too !!
    Does this script change any files or scripts or does change anything in the
    DB ? where can i search for its effects !?

    — note : this why i gave it 1 star and called it really bad plugin :the plugin has no sittings no control, the exclude filter does not work, the damages it causes looks permanent!

    Plugin Author Daniel Roch

    (@confridin)

    The script does not change anything in DB or content. Deactivating it and clearing cache should solve your issue.

    What is your website URL ?

    AboYousef

    (@aboyousef)

    This is a Link for a post in my site with normal slider, you can see
    that the slider is not working

    https://nasser-ss.com/archives/18290

    and hers is another one also with sliders

    https://nasser-ss.com/archives/13765
    the theme is broken since i activated this [plugin and still even after deleting it

    Plugin Author Daniel Roch

    (@confridin)

    It’s weird : the links you provided seems to be generated with W3 Total Cache like if i was already connected to the admin : i see the admin bar.

    You must solve this issue first.

    AboYousef

    (@aboyousef)

    everything was just fine until i installed this plugin, anyway i disabled
    all of W3 caching options and paused all CloudFlare caching but still
    the site is not working
    now on this page i get java errors
    https://nasser-ss.com/home2016

    TypeError: $(...).royalSlider is not a function
    #6 https://nasser-ss.com/home2016:1764:26
    #5 https://nasser-ss.com/home2016:1764:26 HTMLDocument.()
    #4 https://nasser-ss.com/wp-includes/js/jquery/jquery.js?ver=1.11.3:2:27309 j()
    #3 https://nasser-ss.com/wp-includes/js/jquery/jquery.js?ver=1.11.3:2:28122 Object.k.fireWith [as resolveWith]()
    #2 https://nasser-ss.com/wp-includes/js/jquery/jquery.js?ver=1.11.3:2:29956 Function.m.extend.ready()
    #1 https://nasser-ss.com/wp-includes/js/jquery/jquery.js?ver=1.11.3:2:30322 HTMLDocument.J(

    its clear this plugin changed something

    Plugin Author Daniel Roch

    (@confridin)

    Our plugin does not modify any core or plugin and theme file. Your issue is not related to our plugin 🙁

    Did you tried to uninstall W3 Total Cache

    You may alos deactivate all your plugin, and then activate each one after the other to check where the issue is.

    Were you able to solve it?
    since i installed (and then removed it) it messed up all my script;
    it looks i cant no longer call wp_enqueue_script (no script are included when i call it!)
    please dont tell me to clean the browser cache or w3 cache or othet basic things like that!

    Plugin Author Willy Bahuaud

    (@willybahuaud)

    Hello,

    Sorry but I’ll insist: our plugin doesn’t write any file.
    If you deactivate it but you’re problem is still here, it’s because a static cache (on the server side) is not flushed :-/

    ok, i just rebooted the server is it enough?
    since i installed/unintalled your plugin wp_enqueu_script no longer work

    i just added a test in function.php to add an empty script and it is totally ignored

    and it looks im not the only one with this issue

    Plugin Author Willy Bahuaud

    (@willybahuaud)

    Hello,

    If you modify anything else (like a text string in your theme), does this change appear?

    A static cache file can stay actif in your website, even if you reboot your server. It’s the way many cache plugin works. If the problem persist, I suggest you to deactivate all your plugin, and then activate each one after the other to check where the issue is 🙂

    • This reply was modified 2 years, 9 months ago by  Willy Bahuaud.

    i just did ALL the steps
    disabled all plugins (including cache) restartd nginx, restarted varnish
    it just keep ignoring wp_enqueue_script

    i made a sample to load an empty script in function.php and it is ignored

    Plugin Author Willy Bahuaud

    (@willybahuaud)

    And for this step:

    If you modify anything else (like a text string in your theme), does this change appear?

    Your change was visible, or uneffective?

    I wonder, also: does your theme have a wp_head() and a wp_footer() template tags?

    yes to all…
    i can modify template and scripts (and i see it), my theme got wp_head() and wp_footer()

    it seems it just ignore the addition of js

    just to give you another detail im on https (if that count… but i dont think)

    it loads the js from jetpack, but even if i add new plugins or if i try to load some js from function.php it doen not work (but it works with css)
    i just added this in function.php

    
    function empty_scripts() {
    wp_register_script('empty_script', plugins_url('empty.js', __FILE__), array('jquery'),'1.1', false);
    wp_enqueue_script('empty_script');
    }
    
    add_action( 'wp_enqueue_scripts', 'empty_script' );  
    ?>

    it do not add it! (if i echo the script path it is correct)
    it calls the wp_enqueue_script() (i added a debug string in the function);
    but do not put the script in head

    Plugin Author Willy Bahuaud

    (@willybahuaud)

    Maybe the function callback name (empty_script without “s”)? :-/

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘Bad Bad Bad Bad Bad Bad Plugin !!’ is closed to new replies.