WordPress.org

Support

Support » Plugins and Hacks » BacWPup 2.0 and WP 3.2 totally broken

BacWPup 2.0 and WP 3.2 totally broken

  • Big mess. On displaying jobs ovetview I get repeated.

    Warning: in_array() [function.in-array]: Wrong datatype for second argument in /mnt/vhosts/2012worldend.org/httpdocs/wp-content/plugins/backwpup/pages/func_backwpup.php on line 248

    Run Now just hangs no message in Working

    Clicking See Working from the Amin bar goes to job ovetview.

Viewing 15 replies - 46 through 60 (of 105 total)
  • regarding server settings:
    I wrote about the PHP temp folder settings because some hosters have no regular paths so scripts often have problems. I for myself have such a hoster here in Germany and I have a special setting in wp-config for this so all works because of that 🙂
    Mostly you have to contact your hoster if that’s all correct or just google for this hoster with php settings/paths or other problems. If it’s a bigger company mostly you find anything WP related if there were problems in the past with WP.

    However, I am no server specialist at all 🙂 Just a few thoughts for us here… I think Daniel (developer) will look into these issues soon!

    Just another advice: double check your cron/scheduling settings – think twice before you set anything with “any”/”all” check boxes. I had this issue last week so by mistake the cron was about every 3 minutes or so and I was about to crash my system myself… So I made mostly weekly settings on all my projects which work fine.

    -dave 🙂

    @abailey:
    I am not to blame hosting companies! I just have to deal with some unregular settings with my own site just thought it might help some users.

    I am sure, Daniel will look into these issues as soon as he can!

    @daveshine

    Am ruuning my sites on Bluehost webhosting.

    Well, I guess I spoke to soon. The settings worked fine on my smaller site. However, on the larger site, the new Job Settings also got me past the “step aborted has too many tries” error I had been getting. But now, I had a problem with creating the zip file due to the size:

    2011-07-07 04:40.49: 1. Try for make a list of files to Backup ….
    2011-07-07 04:40.50: Files to Backup: 5477
    2011-07-07 04:40.50: Size of all Files: 739.79 MB
    2011-07-07 04:40.50: 1. Try to create backup zip (PclZip) file…
    2011-07-07 04:42.55: [ERROR]Allowed memory size of 67108864 bytes exhausted (tried to allocate 65 bytes)
    2011-07-07 04:42.55: 1. Script stop! Will started again now!
    2011-07-07 10:43.25: [ERROR]Aborted by user!!!
    2011-07-07 04:43.25: Job done in 156 sec.
    2011-07-07 04:43.25: Job done in 156 sec.
    2011-07-07 04:43.25: Job done in 156 sec.

    I guess I have to get with Bluehost on this, unless there is anotehr suggestion…

    Your PHP memory size is 64 MB as I read from your posted log. So this might be way to small to handle such a big backup file with over 700 MB! PHP+Server need create the zip file but run out of memory on that.

    So just try to remove files backup from your job – I suggest DB+WPXML+Optimize+Check. And try again…

    You might also backup your files, wp-content and subfolders for example, via FTP manually. I also exclude files backup on my sites and make this manually from time to time… For me DB and XML backup are most important. Just my opinion…

    -dave.

    @daveshine Thanks will try. Just talked to Bluehost support that also confrmed the 64MB default. They suggested updating the php.ini file to 128MB. Also mentioned not to go above 256MB cause any value higher than that will result in the default (64M) being used. Will try following up on you advice first and let you know, Dave. Thanks. All the best, – Jay

    I found my PHP temp dir, it’s set to the default value (/tmp)
    So every requirement is accomplished.

    I guess the advice by abailey to re-release a patched v1.7.8 is the best way to grant compatibility.

    OK. Just for the fun of it I took the 1.7.8 version and tracked down the problem that was causing grief with v3.2. It was mostly improper constructors in the list-tables.php file.

    I patched them up and tried it on one of my sites that is having major trouble with v2.01. It ran perfectly. Bingo. I can do backups again!

    Tried it on a couple of different hosts that were having the problem and it worked there too!

    Now my only problem is watching that update icon and keeping some one from doing an update.

    I really hope Dan can get 2.0x figured out, it looks like it will be real nice when the bugs are squashed.

    @daveshine Ok, set job for DB+WPXML+Optimize+Check as you suggested. The resulting backup file is 395.23KB (tar.gz) … major difference from 739.79MB !

    One note: After running the backup from the Job menu, I got kicked to the Working menu, which just hung there saying ‘nothing’. After a bit I switch over the Logs menu to confirm if anything had happened. Thought this might be useful to anyone reading this!

    Again, many thanks! – Jay

    Hi jschwartz63

    Thanks for the tip re switching to the Logs menu 🙂

    I just re-ran my table check job and after a few seconds I switched to the Logs menu – for the first time, instead of showing an error (because I had previously aborted an apparently non-working job), it said “O.K”. Progress, I thought 🙂

    Switching back to the Jobs Menu, however, tells me that the job is still running – the only way (I know of) to clear that is to abort the job. Also, on that screen, the options that should appear to edit/run etc my other job have disappeared. That might be by design because it thinks a job is currently underway and doesn’t want me to start another one – I don’t know, but offer the comment here in case it is a bug.

    After aborting the job that was “apparently” still running, I went back to the Logs menu and my “O.K” had now turned into “1 ERROR” which was “[ERROR]Aborted by user!!!”.

    Posting this update in case it helps track down any issues 🙂

    Same for me too 🙁

    Deactivated and reactivated, deleted and recreated job but when I run even a table check it jumps to 100% complete, empty black box but actually never ends (if it even starts). Problem is on checking the logs all I see is [ERROR]Aborted by user!!!

    @abailey
    Could you post an exact workaround, how to get v1.7.8 work properly with WP 3.2, please?

    BackWPup Interim

    I patched up the 1.7.8 version and posted it on my website for those who want to roll back to 1.7.8 patched to work on WP v3.2. You can download it from here

    http://webwrights.com/backwpup-interim

    Hopefully Dan will get 2.x working soon.

    @abailey
    Thanks very much.
    Everything is working fine.

    I want to change the folder that keeps the log files but it doesn’t save the settings in “Settings” log file path reverts back to the default.

    Other than that, my backups are working fine again with latest update. Thanks for the quick fix.

    Plugin Author Daniel Hüsken

    @danielhuesken

    hello i have now hofuly found the problem with zip creation.
    i have also improved the memorx incresement on zip file creation.
    Change of logfile folder works now too.

    Sorry im not at home in moment and make Bugfixes and so on asap.

Viewing 15 replies - 46 through 60 (of 105 total)
  • The topic ‘BacWPup 2.0 and WP 3.2 totally broken’ is closed to new replies.