Support » Theme: Astra » Baclground color in Gutenberg editor

  • carlosvai

    (@carlosvai)


    With the last update of WordPress to 5.7 the option “Use theme styles” is not working.
    The background in the editor is completely white and doesn’t respect the selected theme color anymore.
    Any idea how to fix this?
    Thanks.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Hi @carlosvai,

    I can confirm that the same thing is also happening on my end. I have forwarded this to our team to check further. Thank you for bringing this to our attention.

    This issue will not affect the functionality and how the site works on the frontend though, i.e. the background color is still applied on the page on the frontend. However, we’re still sorry for the inconvenience you may have because of this.

    Kind regards,
    Herman πŸ™‚

    Also experiencing this since updating to 5.7 (Astra 3.1.2). Gutenberg editor is respecting Astra’s font color, but not the background color… resulting in white text on white background for me…
    Thanks,
    Justin

    Experiencing the same since I updated to 5.7 (Astra 3.1.2). I’m using white text, so now with white background it’s making almost impossible to edit or create new content. I need to select the text to se it or I need to use an external addon to turn dark mode on and like that it’s visible.
    See attached picture

    Regards,
    Balazs

    • This reply was modified 1 month, 4 weeks ago by Balazs Ordog.

    Same here. This is really an issue. I am about to add content. But that is not really possible.

    Thanks for a solution.

    Updated Astra to 3.2.0 and still white text on white background πŸ™

    Justin

    Anyone with a solution? This is a discussion in Facebook-Group, too.

    Is this an ASTRA-issue? Or does this affect all wordpress-sites?

    Hi @carlosvai, @jahnstek, @bdog66, @winihh,

    We are really sorry, our team is still working on this. In the meantime, you can add the following snippet to your site to change the editor background color

    add_filter('astra_block_editor_dynamic_css' , 'custom_editor_css' );
        function custom_editor_css( $default ){
            $custom_css = array(
                '.editor-styles-wrapper, .ast-separate-container .block-editor-writing-flow' => array(
    		'background-color'     => '#3f3f3f',
                ),
            );
            $default .= astra_parse_css( $custom_css );
            return $default;
    	}

    You can change the #3f3f3f to any preferred color. And you might want to refer to this doc to know how to add a custom PHP code to your site.

    I hope it will help.

    Kind regards,
    Herman πŸ™‚

    I just updated Astra to 3.4.1 and I can confirm this issue is now fixed (based on changelog, looks like fixed in 3.4.0). The snippet provided above no longer functions and thus I removed it. Thank you for the temporary fix!
    Justin

    I can confirm that the issue is gone! Thanks for the temporary fix!

    Kind Regards,
    Balazs

    focustoinfinity

    (@focustoinfinity)

    Hi all,

    Just found that thread when I was looking for a solution of “white text on white background” in the Gutenberg editor: Since I updated Astra to v. 3.4.1 yesterday, image labels (figcaption-tag) are now displayed with white text on white background in Gutenberg.

    Before the update, text was displayed black. This only happens to those image labels.

    To me, this somehow seems to be related to the problems described in this thread.

    Does anybody else have that problem as well or an idea how to fix it?

    Regards

    Hendrik

    Same here. I have several sites. Many things seemed to be white now in Gutenberg. Experienced white Text aswell.

    But also the whole Gutenberg Layout (Frames) seem to be white. Not easy to work with. But somehow it works. I am not sure this is normal.

    Hi @jahnstek, @bdog66, thanks for your confirmation. Yes, the issue was fixed on v3.4.0.

    @focustoinfinity, we didn’t notice this issue, however, I can confirm that the same thing is happening on my end. I will report this to our concerned dev team and will try to fix ASAP. Thanks for bringing this to our attention and we’re sorry for the inconvenience.

    And @winihh, we have some of our users who reported the page/post editor background color turns to grey after the last update. We plan to include the fix on the next update which should be released soon.

    Kind regards,
    Herman πŸ™‚

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.