Support » Plugin: BackWPup - WordPress Backup Plugin » BackWPup version 2.1.2 new warning.

  • Resolved LMP


    Just updated to version 2.1.2 of BackWPup. I get a warning I did not see before. Thankfully, it does not seem to affect the backup process.

    2011/07/31 16:49.19: [WARNING] pcntl_signal() [function.pcntl-signal]: Error assigning signal
    2011/07/31 16:49.19: [INFO]: BackWPup version 2.1.2, WordPress version 3.2.1 Copyright © 2011 Daniel Hüsken
    2011/07/31 16:49.19: [INFO]: BackWPup comes with ABSOLUTELY NO WARRANTY. This is free software, and you are welcome to redistribute it under certain conditions.
    2011/07/31 16:49.19: [INFO]: BackWPup job: 1. Database Backup to email; DB
    2011/07/31 16:49.19: [INFO]: BackWPup cron: 0 3 * * *; Mon, 1 Aug 2011 @ 03:00
    2011/07/31 16:49.19: [INFO]: BackWPup job strated manualy
    2011/07/31 16:49.19: [INFO]: PHP ver.: 5.2.17; cgi-fcgi; Linux
    2011/07/31 16:49.19: [INFO]: MySQL ver.: 5.2.6-MariaDB-mariadb101
    2011/07/31 16:49.19: [INFO]: curl ver.: 7.15.5; OpenSSL/0.9.8b
    2011/07/31 16:49.19: [INFO]: Temp folder is: /tmp/.backwpup_2619005335/
    2011/07/31 16:49.19: [INFO]: Backup file is: /tmp/.backwpup_2619005335/backwpup_1_2011-07-31_16-49-19.tar.bz2

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author Daniel Hüsken


    if have implemt singal handling for linux hosts.
    can you go over date stamp with your mose and show in the hint to give me the line number? than i now with signal can’t handelt.



    If I understand you correctly, you want the text that appears in the hothelp hint when you mouse over the date on the specific line.

    For the line 2011/07/31 16:49.19: [WARNING] pcntl_signal() [function.pcntl-signal]: Error assigning signal

    The mouseover text is : [Line: 84|File: job_run.php|Mem: 768 KB|Mem Max: 768 KB|Mem Limit: 96M|PID: 3023]

    Plugin Author Daniel Hüsken


    thanks that was it.
    i have removed the problem and u can redownload the version in 15 min. Than the message must gone.



    The warning problem is fixed, but now backwpup displays this message:

    “WP-Cron isn’t working, please check it!”

    By the way, by deleting the backwpup plugin folder (via FTP) and manually re-installing it also solved another (minor) bug: the un-deletable “New” job in the jobs list.



    OK, I managed to fix the error WP-Cron isn’t working, please check it!.

    I suspected that the cause might be the fact that I uploaded the BackWPup plugin manually (i.e. I did not use the built-in WordPress plugin installation page in the dashboard).

    So I deleted the BackWPup plugin again, and installed it through the WP plugin page. Now the error message is gone. 🙂

    I can only assume that this was a file permissions issue. There must be some file in the plugin folder that needs special permissions. Just thought I mentioned it for anyone who has the same issue.

    Plugin Author Daniel Hüsken


    deaktivation and activation helps too 😉

    I’ve got the same issue, but it didn’t go away with deletion and a reinstall.

    I have BackWPUp installed on three sites on the same hosting account.

    One doesn’t give this warning – That site is running Version 2.1.0, and is the one of the three that isn’t locked down with “Private! WordPress Access Control Manager.” Could that plugin be conflicting with BackWPUp? Or perhaps a change in code? I don’t really want to update the plugin on the one that is working, because it is running its scheduled backups perfectly.

    Thank-you for all your work on this plugin! I plan on making a donation here shortly!

    Hi, Same issue again. It disapears on des and reactivation, but the moment I switch to a different plugin the msg appears…

    +1 !

    Same problem here 🙁

    i am also having the same problem. i tried the deactivation->reactivation, and the de-install and re-install, and nothing has helped.

    i can backup manually fine though

    I had the same error message, WP-Cron isn’t working, please check it!.. A deactivation, followed by immediate reactivation, solved it.

    I have the same problem, WP-Cron isn’t working, please check it!
    and Deactivating & activating resolves that.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘BackWPup version 2.1.2 new warning.’ is closed to new replies.