Support » Plugin: BackWPup - WordPress Backup Plugin » BackWPup not working after upgrade

  • Resolved FNGeditor

    (@fngeditor)


    This plugin does not work after upgrade from ver 2.1.17. Both releases of the 3.X version get to 70% and hang there. My sites running the earlier release work fine.
    Fortunately, I tried the backup after updating my first site and did not mess them all up.
    Hopefully, this issue is being actively addressed and a new release will be provided soon. No backups have been completed successfully for the last two weeks.

    http://wordpress.org/extend/plugins/backwpup/

Viewing 15 replies - 1 through 15 (of 44 total)
  • FNGeditor

    (@fngeditor)

    Just to update on the broken BackWPup plugin, I continued to see what I could do to resolve my failing backups. No resolution I could find by adjusting settings on the new interface. Backups still hang. The reviews indicate that this update is a failed update pretty much all around.

    Restoring the plugin from a previous backup did not seem to work for some reason, and the last version I had downloaded was version 2.1.13 (the latest before version 3.0 was 2.1.17). I did find it on WordPress for download though (see below).

    For those who would like to roll back to a functional version, my temporary work around was to confirm my manual settings (directories to exclude, backup location, etc), remove the plugin (be sure your backup location is not in a directory under the backwpup folder, or you will loose those backups)and re-install the plugin by downloading the earlier version (you can pull from the WordPress archive at: http://downloads.wordpress.org/plugin/backwpup.2.1.17.zip ). You will have to reconfigure after install, and you will loose your logs, but the earlier backups will still be available if you observe the note above.

    Hopefully this plugin will be fixed soon, but be sure that I will try on a test site before upgrading BackWPup in the future.

    fredericsidler

    (@fredericsidler)

    Same for me after upgrading to 3.0.4. Nothing works anymore and no logs.

    I’m getting major timeouts and errors now. Never had a problem before. The log also doesn’t seem to work correctly. I cannot see the “live log” like before, now I have to “hope and pray” the job finished, so I can see the log. However, considering I’m getting timeouts that take an hour or more, I have no idea if the job even started, because it’s not in the log list.

    The errors I am now receiving as of 3am (monday) after a full weekend of smooth backups that all run automatically:

    [11-Mar-2013 03:16:28] Compression method is ZipArchive
    [11-Mar-2013 04:17:56] WARNING: Job restart due to inactivity for more than 5 minutes.

    &

    [11-Mar-2013 04:17:56] ERROR: Can not add “wp-includes/js/jquery/ui/” to zip archive!
    [11-Mar-2013 04:17:56] ERROR: ZipArchive returns status: (ER_DELETED) Entry has been deleted

    Thanks for your help!

    Caspar Hübinger

    (@glueckpress)

    Hi FNGeditor,

    +1 for posting your workaround. 🙂 3.0.5 has been released today, haven you tested it? If the issue persists, please consider posting a log file, so we can work on it.

    Thanks,
    Caspar

    Hi! I updated the plugin today, but I’m still unable to get the jobs to run.

    I have 2 quick questions that might answer my problem…

    First some background info…. It used to be that I could hit “Run Job” and the log would pop up and I could watch the backup log live as the job runs. However, after the last week of updates, the log doesn’t pop open any more. This is a problem because, even though it says Job “Job-Name” started, there is not a log afterwards, and I don’t know if it even happened.

    My question is: Was the live log removed from WPBackup intentionally? Or is this an indication that something is wrong on my end?

    Thanks so much!
    Alan

    ZeroGravity

    (@zerogravity)

    @alanudi I am having the same problem.

    fredericsidler

    (@fredericsidler)

    Just upgraded to 3.0.5 and nothing happens. I just tried a DB backup sent by email. Nothing. The test email works, but when I lauch the job, no terminal window with progression is displayed. The only thing that is displayed on the top is “Job “DB Backup” started.”

    Hi, just an update on my status….

    Last night my daily automatic backup did successfully complete, and the log appears to me totally normal.

    However, I am still unable to manually force a backup. It say the job started, but there’s no way to tell if that’s actually true.

    I also created a new backup job that doesn’t run automatically. I hit “run job” and it says it started, but there’s never any log. Under “last run” it says “never”.

    Thanks! I hope you’re having good luck sorting all the work out.
    Alan

    Caspar

    (@friendlyghost)

    @alan You should be able to see a log at “Logs” right in the BackWPup admin menu. Can you post a log file here?

    @fredericsidler Please open a new thread an provide some details, i.e. a log file of the failed job.

    FNGeditor

    (@fngeditor)

    Just an update to all… I just installed the 2.1.17 plugin on a test site of mine, configured and executed BackWPup. It ran fine with and execution time of 66 sec.
    After upgrading to the latest (ver 3.0.6), the manual backup fails still. I was all excited when it passed 70% (after creating the Ziparchive), but hangs at 75%. I didn’t bother waiting until it timed out, but this is the step it always seems to hang at:

    [14-Mar-2013 17:23:13] 1. Trying to create backup archive …
    [14-Mar-2013 17:23:13] Compression method is ZipArchive

    Plugin still fails to function properly. If any of the developers on this thread would like it, I can start it, and just give it the time to fully fail. After that, I can upload and post a link to the log file.

    In the meantime, I would have to say the plugin update is still broken.

    edwinkort

    (@edwinkort)

    My vote also. Above 2.1.7 the plugin is broken.

    RogerWheatley

    (@rogerwheatley)

    You will also find that the backups are password protected when you are able to get the upload to Dropbox working. What are the developers hiding?

    Caspar

    (@friendlyghost)

    @fngeditor

    If any of the developers on this thread would like it, I can start it, and just give it the time to fully fail. After that, I can upload and post a link to the log file.

    Please do!
    Meanwhile, as clear as I understand there’s an issue and I’m hoping we’ll be able to solve it, the plugin is not broken in and out of itself. It works like a charm on what has to be assumed a couple of tens of thousands sites out there (given the 0.5mio downloads it has altogether).
    Dito @edwinkort.

    @rogerwheatley As I suggested here, a support forum sure is the wrong place to start a conspiracy theory. Let’s work on issues and treat each other fair here.

    FNGeditor

    (@fngeditor)

    Anyone reviewing this thread may be interested in the following update involving BackWPup not working after the 3.x.x release. I have really liked this plugin to provide automatic backups of my website, and therefore spent some time trying more experimenting on a test site today (3/19/2013).

    Background on my problem:
    Version 2.1.17 works fine… no problems and backs up in about 1 minute.
    Upgrade to any 3.x.x version gets to creating ZipArchive and just hangs around 70-75% depending on version and other backup settings.

    I tried just about every setting I could, and finally found one that seems to be the culprit on my site. The problem in my case appears to be with the ZipArchive compression function. If the plugin is set for “Auto” or “ZipArchive”, it tries to make a ZipArchive type of backup and hangs. If changed to PclZip, it works every time in a little less time than the previous version.

    To resolve issue with timeout on backups, try this:
    • Under “BackWPup” , select “Settings”
    • From the “BackWPup Settings” Menu, select “Jobs” tab
    • From the Jobs tab, look for “Method for creating ZIParchive” and change to “PclZip”
    • Save your settings and try it again

    I’m not sure about some of the other new settings, and not sure why the auto select function defaults to ZipArchive since the previous version of BackWPup used PclZip for backups, but my main goal was to make it work. I look forward to the next update and hope it resolves this bug.

    Giuliano

    (@klikerko)

    Hi,

    First, this is probably the best backup plugin out there, but it looks like there are some issues that need to be ironed out. I have the same problem as others above.

    I have 4 WP websites hosted on HostGator and one company website hosted on different host. All were working great with version 2 until I upgraded to plugin version 3. Since then all of them are exhibiting exactly the same issue. They just hang at 50%. According to the log from my company website job hanged for more than 4000 seconds. Non of workarounds mentioned above helped with the issue.

    This is the log from one of them. Please note that others are pretty much the same. For security reasons I posted just a last few lines. There were no errors before these lines.

    [20-Mar-2013 10:13:28] Database dump done!
    [20-Mar-2013 10:13:28] 1. Trying to make a list of folders to back up …
    [20-Mar-2013 10:13:28] 346 folders to back up.
    [20-Mar-2013 10:13:28] 1. Trying to create backup archive …
    [20-Mar-2013 10:13:28] Compression method is PclZip
    [20-Mar-2013 10:17:13] ERROR: Aborted by user!
Viewing 15 replies - 1 through 15 (of 44 total)
  • The topic ‘BackWPup not working after upgrade’ is closed to new replies.