Support » Plugin: BackWPup - WordPress Backup Plugin » BackWPup Job Error. Server self connect: Not expected HTTP response:

  • Resolved jorgearmijo

    (@jorgearmijo)


    Im having trouble backing up 2 websites, i have the same configuration in 5 other sites and no problem. this 2 hostings are relatively new (all my sites in godaddy)

    The error in one site: http://www.latitudpickup.com/

    [ Moderator note: code fixed. Please wrap code in the backtick character or use the code button. ]

    
    BackWPup Job Error. 
    Server self connect: Not expected HTTP response:
    Status-Code: 429
    Content-type: text/html; charset=utf-8
    Retry-after: 5
    Content-length: 1281
    Accept-ranges: bytes
    Date: Sun, 11 Sep 2016 09:06:50 GMT
    Age: 0
    X-cache: uncached
    X-cache-hit: MISS
    X-backend: all_requests
    Content: <!DOCTYPE html> <html lang="en"> <head> <meta charset="utf-8"> <title>429 Too many requests</title> <meta name="viewport" content="width=device-width, initial-scale=1.0"> <meta name="description" content="Backend Error page"> <meta name="author" content="Pascal A."> <meta name="generator" content="vim"> <meta http-equiv="Content-Type" content="text/html;charset=utf-8" > <!-- Le styles --> <link href="//netdna.bootstrapcdn.com/twitter-bootstrap/2.2.1/css/bootstrap-combined.min.css" rel="stylesheet"> <style> body { padding-top: 60px; /* 60px to make the container go all the way to the bottom of the topbar */ } </style> <!-- Le HTML5 shim, for IE6-8 support of HTML5 elements --> <!--[if lt IE 9]> <script src="//html5shim.googlecode.com/svn/trunk/html5.js"></script> <![endif]--> </head> <body> <div class="container"> <div class="page-header"> <h1 class="pagination-centered">Error 429 Too many requests</h1> </div> </div> <script src="//netdna.bootstrapcdn.com/twitter-bootstrap/2.2.1/js/bootstrap.min.js"></script> </body> </html>
    

    The error in the other site: http://www.elgranerobrewing.com/

    
    BackWPup Job Error. 
    Server self connect: Not expected HTTP response:
    Status-Code: 429
    Content-type: text/html; charset=utf-8
    Retry-after: 5
    Content-length: 1281
    Accept-ranges: bytes
    Date: Sun, 11 Sep 2016 09:06:54 GMT
    Age: 0
    X-cache: uncached
    X-cache-hit: MISS
    X-backend: all_requests
    Content: <!DOCTYPE html> <html lang="en"> <head> <meta charset="utf-8"> <title>429 Too many requests</title> <meta name="viewport" content="width=device-width, initial-scale=1.0"> <meta name="description" content="Backend Error page"> <meta name="author" content="Pascal A."> <meta name="generator" content="vim"> <meta http-equiv="Content-Type" content="text/html;charset=utf-8" > <!-- Le styles --> <link href="//netdna.bootstrapcdn.com/twitter-bootstrap/2.2.1/css/bootstrap-combined.min.css" rel="stylesheet"> <style> body { padding-top: 60px; /* 60px to make the container go all the way to the bottom of the topbar */ } </style> <!-- Le HTML5 shim, for IE6-8 support of HTML5 elements --> <!--[if lt IE 9]> <script src="//html5shim.googlecode.com/svn/trunk/html5.js"></script> <![endif]--> </head> <body> <div class="container"> <div class="page-header"> <h1 class="pagination-centered">Error 429 Too many requests</h1> </div> </div> <script src="//netdna.bootstrapcdn.com/twitter-bootstrap/2.2.1/js/bootstrap.min.js"></script> </body> </html>
    
Viewing 11 replies - 1 through 11 (of 11 total)
  • Thread Starter jorgearmijo

    (@jorgearmijo)

    Any help?

    Plugin Author Daniel Hüsken

    (@danielhuesken)

    It looks like you use a Varnish Proxy. Can you checkt that /wp-cron.php will not run with the proxy.

    Thread Starter jorgearmijo

    (@jorgearmijo)

    dont understand exactly what to check. here is the wp-cron.php content

    <?php
    /**
     * WordPress Cron Implementation for hosts, which do not offer CRON or for which
     * the user has not set up a CRON job pointing to this file.
     *
     * The HTTP request to this file will not slow down the visitor who happens to
     * visit when the cron job is needed to run.
     *
     * @package WordPress
     */
    
    ignore_user_abort(true);
    
    if ( !empty($_POST) || defined('DOING_AJAX') || defined('DOING_CRON') )
    	die();
    
    /**
     * Tell WordPress we are doing the CRON task.
     *
     * @var bool
     */
    define('DOING_CRON', true);
    
    if ( !defined('ABSPATH') ) {
    	/** Set up WordPress environment */
    	require_once( dirname( __FILE__ ) . '/wp-load.php' );
    }
    
    /**
     * Retrieves the cron lock.
     *
     * Returns the uncached <code>doing_cron</code> transient.
     *
     * @ignore
     * @since 3.3.0
     *
     * @return string|false Value of the <code>doing_cron</code> transient, 0|false otherwise.
     */
    function _get_cron_lock() {
    	global $wpdb;
    
    	$value = 0;
    	if ( wp_using_ext_object_cache() ) {
    		/*
    		 * Skip local cache and force re-fetch of doing_cron transient
    		 * in case another process updated the cache.
    		 */
    		$value = wp_cache_get( 'doing_cron', 'transient', true );
    	} else {
    		$row = $wpdb->get_row( $wpdb->prepare( "SELECT option_value FROM $wpdb->options WHERE option_name = %s LIMIT 1", '_transient_doing_cron' ) );
    		if ( is_object( $row ) )
    			$value = $row->option_value;
    	}
    
    	return $value;
    }
    
    if ( false === $crons = _get_cron_array() )
    	die();
    
    $keys = array_keys( $crons );
    $gmt_time = microtime( true );
    
    if ( isset($keys[0]) && $keys[0] > $gmt_time )
    	die();
    
    // The cron lock: a unix timestamp from when the cron was spawned.
    $doing_cron_transient = get_transient( 'doing_cron' );
    
    // Use global $doing_wp_cron lock otherwise use the GET lock. If no lock, trying grabbing a new lock.
    if ( empty( $doing_wp_cron ) ) {
    	if ( empty( $_GET[ 'doing_wp_cron' ] ) ) {
    		// Called from external script/job. Try setting a lock.
    		if ( $doing_cron_transient && ( $doing_cron_transient + WP_CRON_LOCK_TIMEOUT > $gmt_time ) )
    			return;
    		$doing_cron_transient = $doing_wp_cron = sprintf( '%.22F', microtime( true ) );
    		set_transient( 'doing_cron', $doing_wp_cron );
    	} else {
    		$doing_wp_cron = $_GET[ 'doing_wp_cron' ];
    	}
    }
    
    /*
     * The cron lock (a unix timestamp set when the cron was spawned),
     * must match $doing_wp_cron (the "key").
     */
    if ( $doing_cron_transient != $doing_wp_cron )
    	return;
    
    foreach ( $crons as $timestamp => $cronhooks ) {
    	if ( $timestamp > $gmt_time )
    		break;
    
    	foreach ( $cronhooks as $hook => $keys ) {
    
    		foreach ( $keys as $k => $v ) {
    
    			$schedule = $v['schedule'];
    
    			if ( $schedule != false ) {
    				$new_args = array($timestamp, $schedule, $hook, $v['args']);
    				call_user_func_array('wp_reschedule_event', $new_args);
    			}
    
    			wp_unschedule_event( $timestamp, $hook, $v['args'] );
    
    			/**
    			 * Fires scheduled events.
    			 *
    			 * @ignore
    			 * @since 2.1.0
    			 *
    			 * @param string $hook Name of the hook that was scheduled to be fired.
    			 * @param array  $args The arguments to be passed to the hook.
    			 */
     			do_action_ref_array( $hook, $v['args'] );
    
    			// If the hook ran too long and another cron process stole the lock, quit.
    			if ( _get_cron_lock() != $doing_wp_cron )
    				return;
    		}
    	}
    }
    
    if ( _get_cron_lock() == $doing_wp_cron )
    	delete_transient( 'doing_cron' );
    
    die();
    Thread Starter jorgearmijo

    (@jorgearmijo)

    any suggestions? i really like the plugin and keep using it on every site

    Plugin Author Daniel Hüsken

    (@danielhuesken)

    Use must exclude the wp-cron.php from you Varnish configuration.

    Thread Starter jorgearmijo

    (@jorgearmijo)

    im lost i dont know where to set this up.

    no changes should i make in the wp-config or wp-cron files?

    should i make the setting or call my histing provider? (godaddy)

    thanks

    Thread Starter jorgearmijo

    (@jorgearmijo)

    Hi i already contacted the godaddy tema and they told me that they changed some settings. i also disable the wp-cron in wp-config.php. the error persists:

    Setting	Value
    Setting	Value
    WordPress version	4.6.1
    BackWPup version	3.3.4 Get pro.
    PHP version	5.4.42 (64bit)
    MySQL version	5.5.43-37.2-log
    cURL version	7.45.0
    cURL SSL version	OpenSSL/1.0.1e
    WP-Cron url:	http://www.latitudpickup.com/wp-cron.php
    Server self connect:	Not expected HTTP response:
    Status-Code: 429
    Content-length: 0
    Accept-ranges: bytes
    Date: Mon, 10 Oct 2016 20:19:37 GMT
    Age: 0
    Vary: User-Agent
    X-cache: uncached
    X-cache-hit: MISS
    X-backend: all_requests
    Temp folder:	/home/content/a2pnexwpnas02_data01/47/3508447/html/wp-content/uploads/backwpup-75b0ce-temp/
    Log folder:	/home/content/a2pnexwpnas02_data01/47/3508447/html/wp-content/uploads/backwpup-75b0ce-logs/
    Server	Apache
    Operating System	Linux
    PHP SAPI	cgi-fcgi
    Current PHP user	root
    Maximum execution time	30 seconds
    Alternative WP Cron	Off
    Disabled WP Cron	On
    CHMOD Dir	453
    Server Time	20:19
    Blog Time	14:19
    Blog Timezone	America/Costa_Rica
    Blog Time offset	-6 hours
    Blog language	en-US
    MySQL Client encoding	utf8
    Blog charset	UTF-8
    PHP Memory limit	256M
    WP memory limit	40M
    WP maximum memory limit	256M
    Memory in use	20.50 MB
    Loaded PHP Extensions:	Core, PDO, Phar, Reflection, SPL, SimpleXML, apc, bcmath, calendar, cgi-fcgi, ctype, curl, date, dba, dom, ereg, exif, fileinfo, filter, ftp, gd, gettext, hash, iconv, imagick, json, libxml, mbstring, mcrypt, memcache, mhash, mysql, mysqli, openssl, pcre, pdo_mysql, pdo_sqlite, pspell, session, soap, sqlite3, standard, tokenizer, wddx, xml, xmlreader, xmlrpc, xmlwriter, xsl, zip, zlib
    • This reply was modified 4 years, 11 months ago by jorgearmijo.
    • This reply was modified 4 years, 11 months ago by jorgearmijo.

    I also get this error and I’m also hosting with Godaddy. What could be the reason for this?

    Hello,

    i installed Backwpup but get the information:

    Server self connect: Not expected HTTP response:
    Status-Code: 401
    Server: nginx
    Date: Wed, 22 Feb 2017 03:17:10 GMT
    Content-type: text/html
    Content-length: 188
    Www-authenticate: Basic realm=”hancockteam”
    Content: <html> <head><title>401 Authorization Required</title></head> <body bgcolor=”white”> <center><h1>401 Authorization Required</h1></center> <hr><center>nginx</center> </body> </html>

    I am new to wordpress and it´s probably a very simple problem, but I don´t know how to solve it. I am grateful for any help.

    Hi @trang250393,

    Please create a new topic so that someone will chip in. The OP had a different issue (technically), even though it looked similar by looking at a glance (ex: GoDaddy).

    Plugin Support duongcuong96

    (@duongcuong96)

    Hi @jorgearmijo,
    since we haven’t heard back from you, I’m going to mark it as resolved.
    If you’re still having problems, feel free to let us know ;),
    Cuong

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘BackWPup Job Error. Server self connect: Not expected HTTP response:’ is closed to new replies.