Support » Fixing WordPress » BackWPUp Has Warnings and E-mail Error

  • Mystagogue


    I installed backWPup version 1.3.6 on wordpress 2.9.2. I am hosted on a windows platform. The backWPup tool worked on my local windows box when I requested a database only backup. However when I requested a database and file backup on my hosting provider, the backup failed and provided a log which said this:

    2010-11-23 07:33.23: Database Dump done!
    2010-11-23 07:33.23: Add Database Dump to Backup: my_wordpress_site_78476.sql 1.01 MB
    2010-11-23 07:33.23: Make a list of files to Backup ….
    2010-11-23 07:33.23: [WARNING] opendir(//boswinfs05/home/users/web/b2284/whl.panoply/) [function.opendir]: failed to open dir: Result too large
    2010-11-23 07:33.43: Files to Backup: 744
    2010-11-23 07:33.43: Size of all Files: 9.87 MB
    2010-11-23 07:33.43: Create Backup Zip (PclZip) file…
    2010-11-23 07:34.02: [WARNING] unlink(/boswinfs05/home/users/web/b2284/whl.panoply/wp-content/uploads/pclzip-4cebd0daa4399.gz) [function.unlink]: Permission denied
    2010-11-23 07:34.02: [WARNING] unlink(/boswinfs05/home/users/web/b2284/whl.panoply/wp-content/uploads/pclzip-4cebd0dac0ab6.gz) [function.unlink]: Permission denied
    2010-11-23 07:34.02: [WARNING] unlink(/boswinfs05/home/users/web/b2284/whl.panoply/wp-content/uploads/pclzip-4cebd0dad3397.gz) [function.unlink]: Permission denied
    2010-11-23 07:34.49: [WARNING] unlink(/boswinfs05/home/users/web/b2284/whl.panoply/wp-content/uploads/pclzip-4cebd10942063.gz) [function.unlink]: Permission denied
    2010-11-23 07:34.49: [WARNING] unlink(/boswinfs05/home/users/web/b2284/whl.panoply/wp-content/uploads/pclzip-4cebd10964a9f.gz) [function.unlink]: Permission denied
    2010-11-23 07:34.49: [WARNING] unlink(/boswinfs05/home/users/web/b2284/whl.panoply/wp-content/uploads/pclzip-4cebd1097a6a2.gz) [function.unlink]: Permission denied
    2010-11-23 07:34.49: [WARNING] unlink(/boswinfs05/home/users/web/b2284/whl.panoply/wp-content/uploads/pclzip-4cebd10990ae4.gz) [function.unlink]: Permission denied
    2010-11-23 07:34.49: [WARNING] unlink(/boswinfs05/home/users/web/b2284/whl.panoply/wp-content/uploads/pclzip-4cebd109a36ce.gz) [function.unlink]: Permission denied
    2010-11-23 07:34.49: [WARNING] unlink(/boswinfs05/home/users/web/b2284/whl.panoply/wp-content/uploads/pclzip-4cebd109b870b.gz) [function.unlink]: Permission denied
    2010-11-23 07:34.49: [WARNING] unlink(/boswinfs05/home/users/web/b2284/whl.panoply/wp-content/uploads/pclzip-4cebd109ccaed.gz) [function.unlink]: Permission denied
    2010-11-23 07:34.49: [WARNING] unlink(/boswinfs05/home/users/web/b2284/whl.panoply/wp-content/uploads/pclzip-4cebd109e0ced.gz) [function.unlink]: Permission denied
    2010-11-23 07:34.50: [WARNING] unlink(/boswinfs05/home/users/web/b2284/whl.panoply/wp-content/uploads/pclzip-4cebd10a00f63.gz) [function.unlink]: Permission denied
    2010-11-23 07:34.50: [WARNING] unlink(/boswinfs05/home/users/web/b2284/whl.panoply/wp-content/uploads/pclzip-4cebd10a156df.gz) [function.unlink]: Permission denied
    2010-11-23 07:34.50: [WARNING] unlink(/boswinfs05/home/users/web/b2284/whl.panoply/wp-content/uploads/pclzip-4cebd10a29f75.gz) [function.unlink]: Permission denied
    2010-11-23 07:34.50: [WARNING] unlink(/boswinfs05/home/users/web/b2284/whl.panoply/wp-content/uploads/pclzip-4cebd10a9587e.gz) [function.unlink]: Permission denied
    2010-11-23 07:34.50: [WARNING] unlink(/boswinfs05/home/users/web/b2284/whl.panoply/wp-content/uploads/pclzip-4cebd10ab034e.gz) [function.unlink]: Permission denied
    2010-11-23 07:34.56: Backup Zip file create done!
    2010-11-23 07:34.56: Prepare Sending backup file with mail…
    2010-11-23 07:34.56: Send mail with PHP mail
    2010-11-23 07:34.56: Creating mail
    2010-11-23 07:34.56: [WARNING] date() expects parameter 2 to be long, string given
    2010-11-23 07:34.56: [WARNING] date() expects parameter 2 to be long, string given
    2010-11-23 07:34.56: [WARNING] date() expects parameter 2 to be long, string given
    2010-11-23 07:34.56: [WARNING] date() expects parameter 2 to be long, string given
    2010-11-23 07:34.56: [WARNING] date() expects parameter 2 to be long, string given
    2010-11-23 07:34.56: Adding Attachment to mail
    2010-11-23 07:34.56: Send mail….
    2010-11-23 07:34.58: [WARNING] mail() [function.mail]: Failed to Send
    2010-11-23 07:34.58: [ERROR] Can not send mail: Could not instantiate mail function.
    2010-11-23 07:34.58: Backup Archive File size is 4.52 MB
    2010-11-23 07:34.58: Job done in 96 sec.

    It is strange that the above log said “can not send mail” because nevertheless I did receive the log file by e-mail. That said, backWPup did also create all the .gz files it listed with [warning] statements above. If it had permission to create those files, I’m not sure what other permissions it lacked. Also, I don’t know why it made so many .gz files. Shouldn’t there be only one backup file? And why did it make .gz files, when instead I had requested a zip file?
    I figure I’ve simply done something wrong, and I hope there is a simple answer. Any help?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Mystagogue


    I have an update on this item. I don’t know why, but the 2nd time I attempted a backup, it worked. Or at least it performed the database backup and gave much less warning messages. Unfortunately, no files were backed up, even though they were supposed to be included. Here is a link to the log output:

    There are only a few warnings, and one error about using the e-mail function. Can someone explain what might be causing the warnings and the error?

    The link to the original log file I had from November, which had many warnings and I pasted in my first post, is found here:

    Strange, I am getting the same error. Manual backup does not contain any errors, but the automated backups do and in fact the automated backup is no longer running either. The only changes I made was to check the ‘data optimization and database tables’ check boxes in the backup job’s settings, and that of installing wp super cache; before that those errors were not there!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘BackWPUp Has Warnings and E-mail Error’ is closed to new replies.