Support » Plugins and Hacks » BackWPup - WordPress Backup Plugin » BackWPup 2.01 and DropBox problem

BackWPup 2.01 and DropBox problem

  • Installed version 2.01 on a new site, created a new job, authenticated with DropBox, got the DropBox Authenticated message, saved the job.

    I then tried to run the Job, and was told “BackWPup Working” but the output from the job showed the following error in RED.

    [ERROR] DropBox API: Invalid signature. Expected signature base string:

    It went on to list lots of technical stuff that I can supply directly yo you if you need.

    Above this message on the job log screen it said:

    2011-07-07 01:32.13: 1. Try to sending backup file to DropBox…
    2011-07-07 01:32.14: Authed to DropBox from XXXXX XXX XXXX
    2011-07-07 01:32.14: Free Space on DropBox: 1.94 GB
    2011-07-07 01:32.14: Upload to DropBox now started …
    2011-07-07 01:32.15: [ERROR] DropBox API: Invalid signature. Expected signature base string:…………….

    What am I doing wrong here Daniel? My other Blog (I haven’t upgraded from 1.78 yet until this is stable) has authenticated the same account with DropBox.

    So 1) Why did I get the BackWPup Working message when there was an error displayed in red? 2) How can the job creation screen authenticate with DropBox but the job execution screen fail?



Viewing 15 replies - 1 through 15 (of 15 total)
  • Same problem here…

    I’ve just realised the answer to my own question 1) above.

    I had read “BackWPup Working” as comment that BackWPup is SUCCESSFULLY Working but I now see that it is probably just a comment that BackWPup is in the process of Working.

    Point 2) remains though.

    Same problem here

    [ERROR] DropBox API: Invalid signature. Expected signature base string:

    Plugin Author Daniel Hüsken


    i have changed the oAuth lib in the 2. version.

    The problem is dropbox uses an other server for uploading and downloading files.

    How large the files ? most problems came with files larger than 80MB or when underlines in the destionation folder.

    It’s a new blog so my file was only 860K when compressed.

    I don’t know the DropBox API but the message above suggests that you are passing an incorrect signature base string and that it has nothing to do with file size…

    2011-07-07 01:32.15: [ERROR] DropBox API: Invalid signature. Expected signature base string:…………….


    [ERROR] DropBox API: Invalid signature

    moved to Amazon S3 to test the backup…it works fine.

    My DB is small enough for Dropbox which is where I would like it to go…

    If it authenticates fine…why doesn’t it authenticate properly when the backup string is sent?

    Thanks for working for this Daniel,


    Updated to 2.0.2, but the problem is still the same. Strange thing is I don’t have the problem on two other sites. There is a difference in the sites though, the one with the problem supports something like MLSD (can’t remember exactly what it is, I’m not at home now).

    Keep up the good work , Daniel!

    Funny…it works on one site of mine…and not the other…so I created a second dropbox account and directed the backup to that…didn’t work same DropBox API: Invalid signature

    It is called MLSD indeed.
    There is een thread about it in the Filezilla forum: http://forum.filezilla-project.org/viewtopic.php?f=1&t=12415
    I don’t know if it has something to do with the problem, but I only know that the other 2 sites that don’t have the problem don’t support MLSD.
    Hope this helps….

    Maybe useful info:
    The file is around 30 Mb, but even if I reduce it to around 2 Mb the problem still exists.
    Als the foldername is one word without dashes or underscores.

    If there is some more info you need, just let me know!

    Just tested this with v2.03 and the problem is still there.

    Daniel, any update?

    Still following….same error after 2.03 update – DropBox API: Invalid signature

    Thanks in advance….


    Plugin Author Daniel Hüsken


    can some test the development version ?

    Sure Daniel –

    [email moderated]

    I’d be happy to test too Daniel.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘BackWPup 2.01 and DropBox problem’ is closed to new replies.
Skip to toolbar