Support » Plugin: Contact Form 7 » Backwards incompatible changes are not a thing today

  • Updating to 5.1 broke all sites with recaptcha. Because the author decided we all need to for some reason update to the Recaptcha v3.

    First it doesn’t work with old Recaptcha keys (because v3 keys are incompatible with v2).

    Second it broke the UI. Now all web pages with V3 recaptcha has a recycling badge fixed positioned on the bottom right! The users does not understand what that is. We developers do, but the users don’t. Having a recycling badge fixed on the bottom right of all pages is really bad idea.

    Naturally plugin that is installed on 5 million sites needs to be conservative on changes. There can’t be backwards incompatible changes that breaks the UI or the spam prevention.

    Please add the recaptcha v2 support back in.

  • The topic ‘Backwards incompatible changes are not a thing today’ is closed to new replies.