WordPress.org

Support

Support » Plugins and Hacks » [Resolved] BackUpWordPress 1.6.5 chmod 777

[Resolved] BackUpWordPress 1.6.5 chmod 777

  • Hi everyone

    I got this message:
    BackUpWordPress is almost ready. The backups directory can’t be created because your wp-content directory isn’t writable, run chown qud34Q:g37131 /var/www/g37131/laser-therapie.info/HTML/wp-content or chmod 777 /var/www/g37131/laser-therapie.info/HTML/wp-content or create the folder yourself.

    but backups folder exist with chmod 777.

    I am also using Bullet Proof Security 46.8

    Thank you.

    http://wordpress.org/extend/plugins/backupwordpress/

    P.S.: I downgrad 1.6.4 working fine with no chmod 777 error.

Viewing 15 replies - 1 through 15 (of 18 total)
  • And custom path for backups like
    define( ‘HMBKP_PATH’, ‘/home/willmot/backups/blablabla’
    display the same message of error.

    yes I am continuing getting the same error.

    I am also getting this error on different Web servers(IIS & Apache) and different hosting companies.

    Me too, me too, he cried.

    1.6.4 worked fine. Now getting the same “can’t do it till you create the directory and make it writable” message that Roswebnet describes.

    🙂

    Oh .. using version 3.3.1 of WordPress, which I guess would be helpful for you to know.

    Same problem, worked fine with 1.6.4 until upgraded to 1.6.5. Backup directory already exists. Changed permissions to 777 on wp-content as error message suggests and still “cannot create backup directory”.

    Using WP 3.3.1
    Hosting via 1&1

    Plugin Author Tom Willmot

    @willmot

    Hi All,

    I think this might be to do with the fact that you have capital letters in your path’s

    I’ll release a fix for this today.

    Plugin Author Tom Willmot

    @willmot

    Please test 1.6.6 it should have fixed this issue.

    Seems to have worked for me.

    (1) On a website I had the problem with … 1.6.6 got rid of the error message and seems to have worked OK with a ‘test’ backup I’ve just run. (Info to anyone else – I had to de-activate the plugin version 1.6.5 for the system to see 1.6.6 was available.)

    (2) Updated to 1.6.6 on a site that was running on 1.6.4 – don’t appear to be getting any problems … certainly not the error message I got from 1.6.5.

    (3) Installed on a ‘totally clean’ site (er … I THINK it was totally clean … don’t THINK I’ve downloaded the plugin there before) and again seems to have worked without any difficulties.

    Thanks for the fix … and thanks for the plugin itself. Because it works automatically in the background once it’s installed and configured, it’s very easy to forget it’s there … until you need it! 🙂

    Hi Tom

    it is working now. Great!
    Thank you for your work.

    I have one user request. Can you please add possibility to sent backup to multiple e-mail addresses. Just like this:
    info@mail.mail; info2@help.mail

    Thank you.

    Hi Tom 1.6.6 did the trick. Thanks for the fix and for a great plugin! And yes the path to my backup dir did have some caps… Rob

    Plugin Author Tom Willmot

    @willmot

    Thanks for testing guys, glad 1.6.6 fixed your issues.

    Roswebnet, good idea, I’ve created a ticket https://github.com/humanmade/BackUpWordPress/issues/98

    🙂 great
    I think it should made backup a bit saver. Especially, if somebody has a hosting mail and Gmail or live mail, even for web designers and their clients.
    I mean one e-mail to client and one to web designer so not only web designer is responsible for backup. Otherwise, designer can be a victim for the client 😛 🙂

    Here is the code from php.net, maybe it will be helpful to you.

    [Code moderated as per the Forum Rules. Please use the pastebin]

    Thank you for great plugin.

    Plugin Author Tom Willmot

    @willmot

    I added the ability to send the backup to multiple email addresses in version 1.6.7

    hi i just tried
    and got following errors:
    info@roswebnet.com; email@hotmail.com is an invalid email address.
    also tried in this way:
    info@roswebnet.com;email@hotmail.com

    the same result

    and if i try backup:
    BackUpWordPress has detected a problem. The following email address’s are not valid:

    Plugin Author Tom Willmot

    @willmot

    Hi Roswebnet,

    It looks like you’ve used a semi-colon instead of a comma to separate your email address’s

    Try entering them separated by a comma like this

    info@roswebnet.com, email@hotmail.com

    Hi Tom

    It is working now.Cool 🙂
    thank you.
    Great tool!!!
    Only it will be better if you put some description
    Email backups
    A copy of the backup file will be emailed to this address(es) (separated by comma eg: email1, email2). Disabled if left blank.

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘[Resolved] BackUpWordPress 1.6.5 chmod 777’ is closed to new replies.