Support » Plugin: UpdraftPlus WordPress Backup Plugin » Backups take forever and have warnings

  • Resolved Tina

    (@sunflowermom)


    I have used Updraftplus for years with no problems. Even restored sites with the backups. But lately I’ve been noticing it’s taking longer and longer and now VERY LONG for some of my websites to back up. They seem to crap out constantly. They do eventually finish, but it can take the good part of an hour sometimes. It never used to take this long and the site hasn’t grown significantly.

    The warning message that I am getting is this:
    Warning: Your website is visited infrequently and UpdraftPlus is not getting the resources it hoped for; please read this page:

    But it’s not true, my site IS visited quite frequently.

    Now the one thing that has changed recently is that due to excessive CPU usage, I had to turn off WP Cron and set cron jobs manually through CPanel. It’s the only thing I could figure out that actually brought the usage down. (I’m with Siteground, which I’m now reading is a common problem with this host, excessive CPU usage warnings.) So I imagine this must be related?

    I have no idea how to address it though, to get rid of the warnings and to speed up the backups. Help?

Viewing 7 replies - 16 through 22 (of 22 total)
  • Plugin Author David Anderson

    (@davidanderson)

    Hi Tina,

    The warning indicates that WP Cron is calling UpdraftPlus long after it was scheduled to call it. This indicates that WP Cron is not wokring properly on your site. This is a good (free) plugin to investigate with: http://wordpress.org/plugins/wp-crontrol/ . It will show you the list of registered cron tasks, when they’re scheduled for, and when they eventually run. Lack of visitors is *one* cause, but there are others. One is that WP Cron has been manually disabled on the site, and that a different mechanism has been attempted – either by the site owner or web hosting company – but misconfigured.

    Your last post says that you’ve attempted to do this – so, this is the cause. You don’t run wp-cron.php enough relative to the number of background tasks on your site.

    David

    Thread Starter Tina

    (@sunflowermom)

    Ok, see, now THAT is helpful! And I suspected this may be the issue… I will need to investigate further… I DID manually disable the WP Cron because it was causing issues with my host. Too many calls. I did add my own cron jobs and I thought I did it properly but clearly there’s an issue.

    Ok so I am running into the issue of needing to run cron enough for the jobs but not so much that it sets of alarms with my host, Siteground…

    Do you have experience with Siteground? I’ve read this is a common issue with them. Excessive CPU usage is their issue. I had a dickens of a time reducing it. Finally turned out to be the WP Cron. There must be a happy medium… I believe I have it set currently to run every 30 min. I will double check and post an update. Clearly this isn’t enough.

    • This reply was modified 2 years, 2 months ago by Tina.
    • This reply was modified 2 years, 2 months ago by Tina.
    Thread Starter Tina

    (@sunflowermom)

    Ok, yes, I confirmed that it is every 30 min.
    Here is a screenshot of the settings:
    https://homeschoolrealm.com/wp-content/uploads/2019/06/Screenshot-6.png

    Plugin Contributor bcrodua

    (@bcrodua)

    Hi Tina,

    Apologies for the late reply.

    Are you still having the same issue until now? Have you tried the latest version 1.16.15?

    Regards,
    Bryle

    Thread Starter Tina

    (@sunflowermom)

    Yes, nothing has changed. Still same issues. I know it is because I do not have Wp-cron enabled, but as I said above, it sets off CPU overage alarm bells on my host…

    I did go ahead and turn WP-cron back on on 2 of my very small, very low or no traffic WP installs, to see if that solved the problem and it does. But for my higher traffic site, I am afraid to do this because I imagine it will again make my CPU usage go over.

    Clearly I need to have a different configuration on my manually added cron jobs…but it has to be enough to make Updraft happy, but not so much that it pisses off Siteground.

    Any pointers would be greatly appreciated. Hopefully I can get a response in days instead of weeks this time?

    Plugin Contributor bcrodua

    (@bcrodua)

    Hi Tina,

    I’m afraid there is no other pointers I can give. Our lead developer has already mentioned ways on how to resolve it.

    You could also read some FAQS from our website here which I hope would help – https://updraftplus.com/faqs/my-scheduled-backups-do-nothing-backup-now-stops-midway/

    Regards,
    Bryle

    Thread Starter Tina

    (@sunflowermom)

    Wow. 2 and a half months to give incredibly UNhelpful help. David gave me a wee bit of useful info that I am still trying to work through, but yeah…the amount of back and forth and especially the glaring evidence that responses from your team were posting after not even reading what I had written is just…really unprofessional.

    I have to tell you that your plugin is outstanding. Your tech support. Not. I had plans to eventually, once I had the money, to pay for the service because I really like it that much. But after this fiasco…I don’t feel confident giving money to a company that treats their customers this way.

    Weeks in between responses I actually could have been ok with if your responses were actually showing me that you were truly trying to help by actually being attentive to what I had written was my issue, and giving me HELPFUL INFO. I totally GET that paying customers are the priority and free customers are just not customers. But come on. This was just ridiculous, guys!! Go back and read how bad this went.

    I STILL don’t have an answer really. My host (Siteground) has EXPLICITLY SAID on it’s cron jobs page to NOT set jobs less than 30min. I’m guessing that’s when I run into those CPU Overage issues that they threaten to shut everything down over. That’s why I had to go to manual cron jobs and turn off WP-cron. So I have manual cron jobs set to every 30min. And that is what, I guess, causes your plugin to throw these warnings.

    I have no idea how else to configure it. I’ve said as such and been offered no other advice from you guys. Every few weeks or so when you check in.

    The whole thing is confusing to me especially since I have no scheduled backups. I ONLY backup manually when there are updates (which is several times a week. Wordfence emails me immediately when I need to update. So I’m good.) So I’m not even fully understanding why the cron jobs are so important here. But clearly I am not a coder and don’t get this stuff.

    Anyway, at this point, I’m left after working with your team feeling like if I had other options I would totally take them because god forbid things go really wrong…I have no faith you guys will actually help me in the future.

Viewing 7 replies - 16 through 22 (of 22 total)
  • The topic ‘Backups take forever and have warnings’ is closed to new replies.