WordPress.org

Support

Support » Plugins and Hacks » BackUpWordPress » [Resolved] Backups suddenly jumped from 29MB to 3GB

[Resolved] Backups suddenly jumped from 29MB to 3GB

Viewing 14 replies - 1 through 14 (of 14 total)
  • Aaah, just realised it is so large because it now includes files outside my WordPress installation.

    Is this intentional? If so, can I choose to only download the WordPress files?

    Me again 😛

    Additionally, while I have the settings to “Backup my 3 GB database and files daily at 11:00 pm, store only the last 3 backups on this server.” there are 13 backups displayed in the WP backend, and 14 via FTP.

    Try to remove the old backups and run a backup again to see if it will accumulate.

    Before you changed the seetings, it was adjusted to maintain how many backups?

    Another thing: if you are using another backup solution in you wordpress, check if you excluded the folders in the backupwordpress’s settings.

    just to point my case: here, I use the wpremote solution to download backups remotely, and it created a backup folder in the “uploads” folder. When i run a backup with BackupWordpress, it included this wpremote folder.. and the backups increased the size gradually.

    Thanks gustao.

    I have deleted all the backups. Let’s see now if it limits the number to 3.

    The real problem is that it is backing up files outside the WordPress installation, which total 3GB.

    Perhaps there is there a way to limit backups to the folder ‘wordpress’, that contains the relevant files? Excluding is not an option, as I have a huge list of directories that wish to exclude.

    Plugin Author Tom Willmot

    @willmot

    Hi Caroline,

    The issue with it backing up files outside the WordPress installation has been fixed in version 2.1.3.

    Thanks for reporting the issue!

    Hi again,

    While it may have been fixed for a while – I’ve forgotten if I checked to be honest! – The latest version of backupwordpress is definitely backing up files outside my wordpress installation. These total 5GB – not ideal!

    Is this maybe related to the fact that I have the WordPress files in a /wordpress/ subdirectory, while the index.php and .htaccess files are in the root? As in, my site address is ~.com while the wordpress address is ~.com/wordpress/

    Hope you can help.

    Thanks
    Caroline

    Plugin Author Tom Willmot

    @willmot

    You can force the backup to be taken from the /wordpress/ instead of the server root by adding.

    define( 'HMBKP_ROOT', '/wordpress/' ); to your wp-config.php file.

    Thanks Tom, but where exactly?

    Adding it just under the language options gave a server error on my site.

    Plugin Author Tom Willmot

    @willmot

    Put it just below the WP_DEBUG line.

    What error did it cause?

    You could also use:

    define( 'HMBKP_ROOT', dirname(__FILE__) . '/wordpress/' );

    Both of those give a 500 error.

    Plugin Author Tom Willmot

    @willmot

    Not sure why that would be

    Could you email tom@humanmade.co.uk with a copy of your wp-config.php so I can take a look.

    Plugin Author Tom Willmot

    @willmot

    Resolved off list.

    In case it helps anyone else, this in my wp-config file is what fixed the issue:

    define( 'HMBKP_ROOT', dirname( __FILE__ ) );

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘[Resolved] Backups suddenly jumped from 29MB to 3GB’ is closed to new replies.
Skip to toolbar