Support » Plugin: BackWPup - WordPress Backup Plugin » Backups stopped working on password-protected site

  • Resolved syzygist

    (@syzygist)


    I have a private site with basic htaccess password protection. I have been using BackWPup on it for many years without a problem. However, sometime after 8/25/21 (the last time a backup ran), it stopped working. Now when I try to run a backup job manually, nothing happens.

    In the Settings/Information under self-connect, I am seeing this:

    Not expected HTTP response:Status-Code: 401
    Cache-control: private, no-cache, no-store, must-revalidate, max-age=0
    Pragma: no-cache
    Content-type: text/html
    Content-length: 714
    Date: Tue, 31 Aug 2021 07:10:05 GMT
    Server: LiteSpeed
    Www-authenticate: Basic realm="Inner Sanctum"
    Alt-svc: h3=":443"; ma=2592000, h3-29=":443"; ma=2592000, h3-Q050=":443"; ma=2592000, h3-Q046=":443"; ma=2592000, h3-Q043=":443"; ma=2592000, quic=":443"; ma=2592000; v="43,46"
    Content: <!DOCTYPE html> <html style="height:100%"> <head> <meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no" /> <title> 401 Unauthorized </title></head> <body style="color: #444; margin:0;font: normal 14px/20px Arial, Helvetica, sans-serif; height:100%; background-color: #fff;"> <div style="height:auto; min-height:100%; "> <div style="text-align: center; width:800px; margin-left: -400px; position:absolute; top: 30%; left:50%;"> <h1 style="margin:0; font-size:150px; line-height:150px; font-weight:bold;">401</h1> <h2 style="margin-top:20px;font-size: 30px;">Unauthorized </h2> <p>Proper authorization is required to access this resource!</p> </div></div></body></html>

    Backups on another, public WordPress installation in the same hosting account show Response test OK and are still working fine.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support duongcuong96

    (@duongcuong96)

    Hello @syzygist
    So your site wp-cron.php has password-protected, please try going to BackWPUp -> Settings -> Network -> Authentication method -> set Basic Auth then fill your Basic auth there.
    That should works ^^

    Thread Starter syzygist

    (@syzygist)

    I set that up so long ago I forgot how I did it (though it turns out I made myself a note about it, but I forgot about that too, so I didn’t think to look for one). You are right, somehow the password field got cleared. I re-entered it, and all is well. Thank a lot!

    Plugin Support duongcuong96

    (@duongcuong96)

    @syzygist
    Happy to know the issue is now resolved ^^
    In case you find BackWPUp is useful for you, we would really appreciate it if you leave a positive review and rating.
    This would encourage us to develop new free features and provide free support 😀
    https://wordpress.org/support/plugin/backwpup/reviews/#new-post
    Thank you so much and have a great day!

    Thread Starter syzygist

    (@syzygist)

    BackWPup has already had my 5-star review for a long time, but I updated it to include my appreciation that you provide support here on WordPress.org 🙂

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.