Support » Plugin: DreamObjects Backups » Backups not working

  • Resolved brianstoiber


    I was wondering if this was standard. I activated DreamObjects through the Panel and got DreamObjects Plugin set up in my WP installation. I ran a backup manually and let the automatic one run so it now shows 2 in my bucket. I downloaded both. The file size was much smaller than I expected. It came out to be 44KB and 46KB. But I set it to back up all the files and database, I was thinking somewhere around 50-100MB.

    Also when I tried to open the .zip file, I get the following error:

    Unable to expand “” into “Desktop”.
    (Error 1 – Operation not permitted.)

    Not sure what is happening but I just don’t think this is normal.

Viewing 15 replies - 1 through 15 (of 16 total)
  • Brian, that’s not normal, you’re right.

    Do you get any difference if you backup just SQL and just the files separately?

    Backing up the the Database works fine. Backing up All Files alone gives me the expanding error same as having both checked. So the problem I am having is when All Files is checked.

    I pushed a 2.2 update yesterday, have you tried after updating?

    (Honestly I don’t expect that to actually magically fix it, I’m just curious if I fixed a random bug while I was at it)

    Yes, I updated about an hour ago and then checked for the backups to see if they were working.

    Fond hopes, I have few.

    Do you have any non-WP folders in your install? Or any password protection via .htpasswd on a folder?

    There is a folder named “git” with the files “.htaccess” and “.htpasswd” from when I was going to instal Git on my server but never got around to finishing it. Also “.htaccess” in the root directory. Should I delete that directory?

    If you’re not using them, yes, that wouldn’t be a bad idea. If you are using them, of course, I’ll have to tell the plugin not to backup non WP files 😉 I should probably do that anyway.

    unfortunately when I try to delete them via FTP I get an Error 500 permission denied. Not sure how I am going to delete them, so I might need to just wait for you to update.

    I took a peek at your server. There’s an auth.php file in your wp-content/uploads folder that caught my eye. You may want to ask the DreamHost security guys to run a scan on your account, since that looks a little off to me.

    (I am working on making WP only backup WP folders, but I have to sort out the best way to detect where wp-content may be moved to…)

    Just installed the plugin in latest version of WordPress. It will create a manual copy of the sql file which appears normal.

    If both backup files and data are checked it doesn’t backup anything.

    Thanks, kvento. I’m trying to figure out exactly why it decides to do this. It actually makes the backup but dies on copy, so I’ve been trying to get some error trapping/logging that would tell me exactly where it’s croaking.

    Happy new year 😀

    Okay, the 2.3 beta version has logging. It’s not 100% ready for release, but it’s working on my test sites (and live site), so if you want to run with it:

    There are some other security changes, like after you set your keys, they no longer display in wp-admin (though you can see them in your database). Also there’s a ‘reset’ button which does exactly what it sounds like.

    The logging is on the main settings screen and logs to a flat text file. There’s really nothing dangerous in it, so leaving it up won’t kill you, but it’s not something I’d leave forever. When you run a backup, it’ll do this:

    [2013/01/03 02:33:48] Scheduled ASAP backup.
    [2013/01/03 02:33:51] List of files added to the zip.
    [2013/01/03 02:33:51] SQL file created (1 MB).
    [2013/01/03 02:33:51] SQL filename added to zip.
    [2013/01/03 02:33:53] Zip generated (10 MB).
    [2013/01/03 02:33:54] Copying backup to DreamObjects.
    [2013/01/03 02:33:54] Deleting zip.
    [2013/01/03 02:33:54] Deleting SQL dump.

    When you save settings it’ll do this:

    [2013/01/03 02:34:33] Scheduled daily backup. Next backup: January 4, 2013 02:34 pm

    Also it no longer kicks off a backup when you save settings (which was killing some people’s sites).

    Remember, this is the beta release, so I expect to find bugs :/

    Just wanted to say thanks. That worked perfectly. I have a 48 MB zip file now.

    Wow. Okay, that was unexpected, but I’ll take it as a win 🙂

    At 48MB you may be hitting the practical size limit (apparently while CEPH can take up to a 2G file, it can only do 200Meg comfortable via PHP, and PHP itself doesn’t like anything over 50M). I’ve been working on multipart threading (i.e. breaking up the upload into smaller chunks) to work around that limit.

    I do have all the default themes installed that DreamHost installs, so deleting those should help a lot.

    …I also was able to get rid of those password files with Dreamhost support. So that is probably what did it.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Backups not working’ is closed to new replies.