Support » Plugin: BackUpWordPress » Backups not finishing

  • Hello,

    My backups have not been completing. I have a schedule set up, but the “database and files” backup will never finish – it goes on and on for days. I can, however, just back up the database. What’s going on and what can I do to fix it?

    Thank you and I look forward to hearing back!

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author katmoody

    (@katmoody)

    Hi there,

    It sounds like there’s a problem with the files-backup. Try following some of these tips to see if we can help isolate the issue you’re having:

    • Can you run a files-only backup? (not the complete backup – create a new schedule if you don’t want to edit a current one)
    • If not, try to exclude your /wp-content/uploads folder, then run a manual backup. Does this work? If so, we know the size of your backup is probably hanging up your server.

    Let me know what you find out and we can troubleshoot from there,
    Kat

    It is possible to do a backup without “uploads” folder? I think it should be important for a future reposition of the site.

    Plugin Author katmoody

    (@katmoody)

    You’re right! This is something we do just for testing purposes 😉

    That will tell us if the backups will complete but can’t because of some kind of limit.

    Let me know what you find out? 😀

    Thanks!
    Kat

    I solved my problem of backups not finishing.
    it was someone eleses pluging stoping this from getting the file size in excludes.
    I worked a lot trying to verify my permissions. and when at wits end.
    I disabled most of my plugins. and wala I was able to see file size on the exclusions page, the backup finished. now I just have to narrow down which plugin was killing this one.

    Plugin Author katmoody

    (@katmoody)

    That’s good news @semky

    If you figured out which plugin was the culprit can you make sure and let us know? I’ll do additional testing on our end and see if we can figure out why.

    Thanks!
    Kat

    I found that plugin ” Advanced Ajax Page Loader ” would stop the backup.

    also found I could not delete the oldest backups. was permission thing.
    so did that manually.with filezilla.

    also found that the excludes page was not listing the file size.
    so I checked permissions.again till it shows file size.

    Still seems like permissions are two loose. why would others need any permissions. at all. as long a apache,ftp & admin. are in the same group.

    A confused interface.
    On the fieldset below ” if your finding BackupWordPress useful.
    “Complete Manually (0) File Manually (0) File Manually (5) + add schedule”

    Should they not have some indication that these are more like anchors
    or links (hyperlink blue) I thought they were there for just information.
    But when I was actually selected on the Fieldset it showed
    No backups completed and was confusing.
    This user interface might cause of some of the problems in using the plugin.

    Plugin Author katmoody

    (@katmoody)

    That’s a great point about the interface – I’ll definitely make a note of that for the next release.

    I’m not positive about the permissions, but I’ll check on that.

    Kat

    @katmoody Sorry to come back to this thread late. Thank you for your reply and help.

    I tried running a files only backup and it did not work – it still goes on and on forever.

    How do I exclude the /wp-content/uploads folder? I don’t see an option to do this.

    Your help is much appreciated and I look forward to hearing from you,
    Abigail

    Plugin Author katmoody

    (@katmoody)

    Hey there –

    You can read this article for more information on how to exclude files: https://bwp.hmn.md/knowledge-base/exclude-files-files-backups/

    And keep in mind that if it does complete after you’ve excluded that folder, it’s likely you will want to check with your host or directly edit your php.ini file/server settings. There’s a bit more info on php.ini settings here: https://bwp.hmn.md/knowledge-base/editing-php-ini-improve-backupwordpress-performance/

    Let me know what you find!

    Kat

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Backups not finishing’ is closed to new replies.