Support » Plugin: WordPress Backup and Migrate Plugin - Backup Guard » BackupGuard Error: PHP EXECUTION TIMEOUT ERROR

  • Resolved canadianangelxo

    (@canadianangelxo)


    Hi there, I have been trying to back up my WordPress site with Backup Guard for almost a week now and I keep getting this error.

    BackupGuard Error: PHP EXECUTION TIMEOUT ERROR
    Your hosting has an execution time limit of 5000 seconds for PHP scripts, which is not enough for performing a full backup/restore of your website. A full website backup/restore is a complex process which may take a couple of minutes depending on many circumstances. The needed execution time varies depending on the backup options and your server performance, that’s why we cannot tell exactly how much execution time is needed. But, almost all hosting providers give users the ability to increase the execution time limit or they increase it themselves, upon user request. Please ask your hosting provider if they are able to increase your execution time limit. If this isn’t an option for you, then try to activate the “Reloads enabled” option in the settings (to compress your data chunk by chunk). Then disable any security plugin which could prevent nopriv ajax calls and try again to create a new backup. If you still see this error, please contact us and we’ll do our best to help you figure it out ASAP.

    I have tried the solutions in the error message, to no avail. I’ve also had several conversations with my host, who have increased the execution time, all the way up to 50000, yes 50,000! I am still getting this error.

    Backup fails whether I do a full backup or backup the files and database individually.
    Wordpress and the plugin are both updated to the most recent versions.

    Backups were working correctly before this error started occurring. Please advise. I’d hate to have to find another Backup solution.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.