Support » Plugin: Transparent Image Watermark » Backup system : Error

  • Resolved TraitPlat

    (@traitplat)


    Hello,
    How Work the new feature “Backup System” Please ?

    And when I enabled it, I get this error message that appears when I uploads an image:

    Warning: array_key_exists() [function.array-key-exists]: The second argument should be either an array or an object in /home/***/www/wp-content/plugins/transparent-image-watermark-plugin/transparent-watermark-tools.php on line 419

    How Fix this ?

    Thx.

    http://wordpress.org/extend/plugins/transparent-image-watermark-plugin/

Viewing 11 replies - 1 through 11 (of 11 total)
  • I forgot to mention: WordPress MU, plugin not enabled on the network, but only on sites that needs it.

    Plugin Author MyWebsiteAdvisor

    (@mywebsiteadvisor)

    Thank you.
    We believe this should be resolved with new update v2.3.9
    Please let us know if you have any further issues.

    The way it works is very simple.
    Each time an image is watermarked, a backup copy is made.
    The watermark can then be removed via the edit media page, using the ‘remove all watermarks’ button which will revert all sizes of that specific image to the backup copies.

    Thank You!

    Thank you for your quick response.
    I asked for the operation because I do not see the “‘remove all watermarks” button, but maybe that’s because of the bug?

    Plugin Author MyWebsiteAdvisor

    (@mywebsiteadvisor)

    The backup function was added to the program recently, only images which have been uploaded since that update were applied would have a backup.

    If you add a new image you should see the remove watermarks button.

    Thank You!

    Yes, I did a test just after the update. But I do not see Button like this.
    And, of course, the backup option is enabled when I test.

    Plugin Author MyWebsiteAdvisor

    (@mywebsiteadvisor)

    Do you also have the option ‘Show Advanced Features’ set to ‘Enabled’?

    When that is enabled you should see a list of the associated image sizes with preview links on the edit-attachment screen. Do you see that?

    The ‘Add Watermark’ button obviously does not work in the free version, however you should also see the ‘Remove All Watermarks’ button.

    Thank You!

    Sorry, I read too fast and I do not pay attention to this option, I thought it was designed only to ULTRA release.

    I enabled but I receive this error message appears :

    Warning: filemtime() [function.filemtime]: stat failed for /home/xavboxb/www/files/2013/05/IMAG0130.jpg in /home/xavboxb/www/wp-content/plugins/transparent-image-watermark-plugin/transparent-watermark-plugin.php on line 1206
    
    Warning: filemtime() [function.filemtime]: stat failed for /home/****/www/files/2013/05/IMAG0130-1024x612.jpg in /home/xavboxb/www/wp-content/plugins/transparent-image-watermark-plugin/transparent-watermark-plugin.php on line 1232
    
    Warning: filemtime() [function.filemtime]: stat failed for /home/****/www/files/2013/05/IMAG0130-300x179.jpg in /home/xavboxb/www/wp-content/plugins/transparent-image-watermark-plugin/transparent-watermark-plugin.php on line 1232
    
    Warning: filemtime() [function.filemtime]: stat failed for /home/****/www/files/2013/05/IMAG0130-150x150.jpg in /home/xavboxb/www/wp-content/plugins/transparent-image-watermark-plugin/transparent-watermark-plugin.php on line 1232

    but the boutton ‘Remove All Watermark” is here 🙂 .

    Thx for Help.

    Plugin Author MyWebsiteAdvisor

    (@mywebsiteadvisor)

    We have also fixed the filetime issue with another release today, v2.3.10 should resolve that for you.

    Thank you for your patience!

    Thx you for everything !
    I’ll wait.

    Thx for the update, now all work perfectly !

    GG

    Plugin Author MyWebsiteAdvisor

    (@mywebsiteadvisor)

    Thank you for your help!

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Backup system : Error’ is closed to new replies.