Support » Plugin: BulletProof Security » Backup suddenly in wrong path

  • Resolved Pieter

    (@pieter)


    After the latest update of BPS I got a warning in admin.
    This could have to do with the move to another hosting recently, I guess.
    What is the best way to solve this?

    I got this warning (changed some parts here for security):

    Warning: is_dir(): open_basedir restriction in effect. File(/home/myname/public_html/wp-content/bps-backup/backups_somestuffhere) is not within the allowed path(s): (/var/www/vhosts/domain.org/:/tmp/) in /var/www/vhosts/domain.org/httpdocs/wp-content/plugins/bulletproof-security/admin/includes/admin.php on line 661

    WP 4.9.9
    BPS 3.3

    Thanks in advance!

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author AITpro

    (@aitpro)

    Personally I recommend that you disable open_basedir in your php.ini file, but if that is not possible to do then you would need to include your web hosting account root folder in your php.ini server config file or your custom php.ini file > /var/www/vhosts/domain.org/httpdocs/. Something is not right though because you have this additional web host root account folder > /home/myname/public_html/. Maybe there is some left over DB info in your WordPress DB that needs to be updated. Try rerunning the BPS Setup Wizard again and let me know if you are still seeing the same php error.

    Plugin Author AITpro

    (@aitpro)

    Also if this is specifically related to doing a DB backup then create a new DB backup job in BPS DB backup. The way the BPS DB backup values are stored in your WP DB are most likely trying to find a web host directory that no longer exists since you moved to a different web host.

    • This reply was modified 2 years, 8 months ago by AITpro.
    Plugin Author AITpro

    (@aitpro)

    Is the issue/problem still occurring or is it resolved?

    Thread Starter Pieter

    (@pieter)

    Sorry, just too busy recently.
    I’ll come back to this asap.

    Thread Starter Pieter

    (@pieter)

    Hi,

    Thanks for your help.
    I have no access to the server configuration myself.

    I rerunned the BPS Setup Wizzard, which gave all green, but …

    BPS Setup Verification & Error Checks
    BulletProof Security JTC-Lite Options Setup
    
Notice: Undefined index: bps_jtc_custom_form_error in /var/www/vhosts/example.com/httpdocs/wp-content/plugins/bulletproof-security/admin/wizard/wizard.php on line 848

    No backups here but warnings
    In the backup section:
    Warning: file_exists(): open_basedir restriction in effect. File(/home/myname/public_html/wp-content/bps-backup/backups_XvOs8l2fZ332nbr/.htaccess) is not within the allowed path(s): (/var/www/vhosts/example.com/:/tmp/) in /var/www/vhosts/example.com/httpdocs/wp-content/plugins/bulletproof-security/admin/db-backup-security/db-backup-security.php on line 132

    Warning: copy(): open_basedir restriction in effect. File(/home/myname/public_html/wp-content/bps-backup/backups_XvOs8l2fZ332nbr/.htaccess) is not within the allowed path(s): (/var/www/vhosts/example.com/:/tmp/) in /var/www/vhosts/example.com/httpdocs/wp-content/plugins/bulletproof-security/admin/db-backup-security/db-backup-security.php on line 133

    Warning: copy(/home/myname/public_html/wp-content/bps-backup/backups_XvOs8l2fZ332nbr/.htaccess): failed to open stream: Operation not permitted in /var/www/vhosts/example.com/httpdocs/wp-content/plugins/bulletproof-security/admin/db-backup-security/db-backup-security.php on line 133

    Warning: is_writable(): open_basedir restriction in effect. File(/home/myname/public_html/wp-content/bps-backup/backups_XvOs8l2fZ332nbr/.htaccess) is not within the allowed path(s): (/var/www/vhosts/example.com/:/tmp/) in /var/www/vhosts/example.com/httpdocs/wp-content/plugins/bulletproof-security/admin/db-backup-security/db-backup-security.php on line 136

    Hope this makes it more clear where the solution should be?
    Thanks a lot in advance.

    Plugin Author AITpro

    (@aitpro)

    Try these steps below:

    Go to BPS DB Backup > click the Create Backup Jobs accordion tab > click the Rename|Create|Reset Tool button.

    Now try running the BPS Setup Wizard again.

    If that does not work then try uninstalling and reinstalling the BPS plugin.

    • This reply was modified 2 years, 8 months ago by AITpro.
    Plugin Author AITpro

    (@aitpro)

    []

    • This reply was modified 2 years, 8 months ago by AITpro.
    Thread Starter Pieter

    (@pieter)

    Yes!
    That did it.
    Rename-create-reset button and then Setup Wizard.
    You know your stuff. 🙂
    Thanks very much.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Backup suddenly in wrong path’ is closed to new replies.