WordPress.org

Forums

DreamObjects Backups
[resolved] Backup schedule date bug? (59 posts)

  1. insin
    Member
    Posted 2 years ago #

    Attempting to use the backup functionality.

    The schedule date being presented to me is:

    Next scheduled backup is at December 31, 1969 08:00 pm

    The on demand backup also fails.

    The message displayed when attempting the on demand backup shows that it uses WP date and time settings. I checked my setting in the wp-admin interface and everything is accurate, based on my timezone. Should I be looking somewhere else for these date\time settings?

    *note that I'm hosting my WP site with DreamHost

    http://wordpress.org/extend/plugins/dreamobjects/

  2. Ipstenu-DH
    DreamHost Rep
    Posted 2 years ago #

    insin - Thank you for that fantastic bug report!

    And that may be exactly why some people are having issues. Can you tell me your domain name and I'll go look on the server?

    If you don't want to post it, you can email me at mika.epstein at dreamhost.com

  3. insin
    Member
    Posted 2 years ago #

    Thanks Mika, I've just sent you an email. Format of my address is a bit strange so it might hit your spam box.

  4. Ipstenu-DH
    DreamHost Rep
    Posted 2 years ago #

    Got it and sent a reply. I think I was doing something wrong :) Or rather, not as good as it could have been ;)

  5. Matt
    Member
    Posted 2 years ago #

    I'm having the same problem.

    "Next scheduled backup is at December 21, 2012 02:25 pm"

    It's already 7 PM.

    ASAP backup button does nothing as well.

  6. insin
    Member
    Posted 2 years ago #

    Mattjsrules,

    After selecting the backup options (Files, DB checkboxes; Schedule interval etc.), try hitting the "Update Options" button before the ASAP button. This might correct the date and then get the ASAP and interval schedules working for you.

  7. Matt
    Member
    Posted 2 years ago #

    My date is not showing 1969... it's showing the current year.

    I'm having a problem where all the info is correct, but no backups will occur.

    Plugin seems to be stuck.

    Still says "Next scheduled backup is at December 21, 2012 02:25 pm" and it's already 8 PM.

    ASAP button doesn't start a backup either.

    I just started using the service yesterday.

  8. insin
    Member
    Posted 2 years ago #

    Sorry, I meant to say the 'Update Options' action "might correct the date\time", not just the date.

    Was hoping my experience might help you out but in this case the plugin authors may provide better insight.

    Good luck!

  9. Matt
    Member
    Posted 2 years ago #

    Deleted the plugin and re-installed and the time is still stuck... =( still no backups.

    I appreciate your help.

    No offense to the developer, but the plugin seems very sensitive and it doesn't want to work.

    I know the service is new, but it's been out for several months now.

    Good thing I am on trial. I would not pay for a service that's still in beta. It sounds good, but it still needs more work before I would consider using the service as a serious backup solution.

    *Update* Saw that this is not an official plugin -- sorry

  10. Matt
    Member
    Posted 2 years ago #

    When I re-install plugins it regrabs the settings I had before.

    Is there anyway to do a clean re-install of the plugin so I can see if re-installing will help?

  11. Matt
    Member
    Posted 2 years ago #

    Now the plugin shows this error:

    Warning: S3::listBuckets(): [403] Unexpected HTTP status in /home/mattsuda/mattsuda.com/wp-content/plugins/dreamobjects/lib/S3.php on line 249

    And the DreamObjects options in my DreamHost panel now says:

    "THIS DREAMOBJECTS USER HAS NO ACTIVE S3 KEYS! YOU WILL NOT BE ABLE TO SEE BUCKETS AND OBJECTS IN THE PANEL UNTIL YOUR PENDING S3 KEYS ARE CREATED."

    And I have 2 keys created...

    Nothing but constant problems with this service/plugin

  12. Matt
    Member
    Posted 2 years ago #

    My DreamObjects bucket is now stuck on creating a new key and I can't create more new keys in the meantime. What do I do?

    Sorry for all the questions, but this service seems totally broken.

  13. Matt
    Member
    Posted 2 years ago #

    Ok got the new keys working...

    Time changes, but date is always stuck on "December 21, 2012"

    Seems like it's stuck on the Mayan calendar (joke)

    No backups are even created on schedule because of the time bug and ASAP button doesn't create a backup.

    Uninstalling the plugin doesn't get rid of the whole plugin because on reinstall, everything is returned to how it was before the uninstall.

    How are people supposed to use this plugin?

    What do I do?

  14. Sorry, Matt, it's the weekend. While I can (and do) support this as part of my job, you have to remember I don't work 24/7 ;) The plugin isn't official, and it's still very new. Part of why I felt it was 'ready' to be pushed in the newsletter is that one person can only test so much :) You guys have myriad installs I could never replicate, and this is the best way to find bugs I've missed. I'm sorry it's not perfect, but I've been working hard on it.

    Isin's issue was fixed so I should have marked this resolved. Once

    Your's is a different error, and realistically you should always make a new topic for that :)

    If you could go to the backups page and change Schedule to 'Disable', try the ASAP button again?

    After selecting the backup options (Files, DB checkboxes; Schedule interval etc.), try hitting the "Update Options" button before the ASAP button. This might correct the date and then get the ASAP and interval schedules working for you.

    Also did you try that? It's, in effect, a reset.

    If that doesn't work, please try downloading the trunk version: http://downloads.wordpress.org/plugin/dreamobjects.zip (this version properly uninstalls, if you deactivate and remove via the Admin Panel).

    I've made some changes to how the plugin handles scheduling, which should work in more situations.

  15. Matt
    Member
    Posted 2 years ago #

    Alright, thanks! I wasn't trying to be negative, I do think the idea is great.

    I'm not in a rush -- so I can be as patient as possible.

    This new version fixed the uninstall problem. =)

    However backup ASAP and scheduled backups still don't work.

    Look at the screenshot below -- I am getting times that have already happened today. It's currently 9:15 PM on December 22nd and it's showing times for earlier this morning.

    I get 3 different backup times in this screenshot (I just clicked ASAP backup before taking this screenshot)

    *Update* Before I took this screenshot it said December 22nd, but after I refreshed it changed to December 23rd before I took the screenshot

    http://www.mattsuda.net/images/dreamobjects/bug.png

    And here is the time that is shown in my WordPress settings as of 9:17 PM

    http://www.mattsuda.net/images/dreamobjects/time.png

    I followed your suggestion, and when I disable scheduling and then do an ASAP backup, it says the ASAP backup is scheduled for 3 PM today, but 3 PM today already happened.

    Below the ASAP backup, it always shows a different scheduled time than what it says in the option above it.

    "Keep in mind, your next scheduled backup is (date is same, time is different)

    The ASAP notification bar at the top and the displayed "keep in mind date" always seem to be some time at 3 PM.

  16. The "keep in mind" won't change unless you re-save the settings handled in update options :) If you change the daily/weekly/etc or what you backup, it makes a backup right away, which sets the next one to 24 hours from now.

    So two times are 6 hours off. Well ... that's certainly weird! *hrmp*

    When I get back to my grown up computer, I'll take a look and see if I can break it that way. What themes are you running?

  17. Matt
    Member
    Posted 2 years ago #

    Yeah, I figured out that the time shown is 24 hours from the time that I clicked on save.

    I don't know why one reminder is showing a different time than the other.

    I'm running a custom theme based off of "paragrams".

    I basically took most of the code and tweaked it.

    Whatever info you need to fix it -- I can give it to you. Just let me know.

  18. Matt, I pushed a new version of the plugin. Can you test that?

  19. Matt
    Member
    Posted 2 years ago #

    Is there a new version? I'm still seeing 2.1

  20. That was the new, I wasn't 100% sure which one you were on. I knew you'd downloaded the 'trunk' version. You may need to manually reinstall it, depending on when you downloaded it.

  21. Matt
    Member
    Posted 2 years ago #

    My post:
    http://wordpress.org/support/topic/backup-schedule-date-bug?replies=17#post-3647910

    was for Version 2.1, and backups still don't work.

    Whatever info you need to fix it -- I can give it to you. Just let me know.

  22. Are you hosted at DreamHost? (I'm assuming yes ;) ) - If you just want to say what the URL is of your blog, I can look at it.

  23. Matt
    Member
    Posted 2 years ago #

  24. Wow. Okay, there are a lot of plugins :D I'm going to see if I can reproduce this one based on your setup.

  25. Matt
    Member
    Posted 2 years ago #

    Just deleted a whole bunch of plugins that were not activated to make it easier. I needed to clean some out some of the plugins I never used anyway. =)

  26. Okay, tell me if your site looks okay with the times now? I think I fixed the time displaying wrong, but that doesn't answer why the ASAP doesn't work.

    ETA: Also do you have it scheduled right now?

  27. Matt
    Member
    Posted 2 years ago #

    Times are now correct

    Backups still not working... really weird.

  28. Matt
    Member
    Posted 2 years ago #

    I'll check if a backup was made tomorrow now that the times are correct. (Daily backup is on)

  29. FWIW, the dates were just being converted wrong. They were stored correctly in the DB :)

    If you would be so wonderful as to try changing the backup to 'disabled' and then back to 'daily', that would be great :) I looked at your DB and didn't see the cron job scheduled, and that may be a big clue for me. :)

  30. Matt
    Member
    Posted 2 years ago #

    Ok I disabled backup, and re-enabled daily.

    Backup ASAP seems to be working although the notification that shows on top has the wrong time after pressing the button.

    I'm testing it several times to make sure it works and that all files are backed up.

    *will update this post soon when I get more info*

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • DreamObjects Backups
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic