WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Backup Plugin Error

[Resolved] Backup Plugin Error

  • Hi there,

    First of all, I’d just like to say thanks to the developer for this module – it has the potential to be such an excellent addition to any WordPress blog.

    I’m experiencing a couple of problems with the module though.

    First of all – the backup isn’t getting transfered to my Google Drive (I’ve tried this on 3 of my blogs – and all with the same outcome):

    2012-05-20 14:36:26 NOTICE Attempting to upload archive to Google Drive
    2012-05-20 14:36:26 ERROR Failed to upload archive to Google Drive!

    Secondly, now that I have the maximum backups created (I’ve set this to be 3, I’m also getting another error:

    2012-05-20 14:36:40 NOTICE Attempting to create archive /home/theblogg/public_html/leestewie/wp-content/backup/1337524600.zip
    2012-05-20 14:36:47 ERROR There was a problem creating the zip file! /home/theblogg/public_html/leestewie/wp-content/plugins/backup/backup.php 290

    Thirdly, the frequencies appear to be incorrect. For example, I select ‘Monthly’ to be ‘When to Backup’ and for some reason the next Backup is going to be December?

    Any ideas?

    As I say, this is going to be a brilliant plugin – just seems there’s a couple of issues to still be ironed out (unless I’m being really thick – then I apologise!)

    Cheers,

    Lee

    http://wordpress.org/extend/plugins/backup/

Viewing 15 replies - 1 through 15 (of 46 total)
  • Ok… regarding the second point I made – might have found the problem for this. It seems there wasn’t enough space avalible to save the backup in the /backup/ folder. Can there be an option to remove the backup from the server? In theory the backup that should go to Google Drive is an exact replica so there’s perhaps less of a need for both.

    Hi Lee,

    First of all thank you for your great feedback!

    I will try to answer your questions/issues in reverse order.

    1. I solved the frequency problem. It was a miscalculation on my part.

    2. As it is right now, if you set the number of backups to 3, you will end up always having the 3 most recent backups on both Google Drive and your wp-content/backup folder. Would you like an option to not have any backups kept in the wp-content/backup folder?

    3. The failure to upload to Google Drive is a bit more difficult to tackle because as it stands the Google Drive/Docs API is undergoing a lot of changes and I have found that while one implementation might work for me it might not work for others.

    I will have to extend the log file to include the HTTP responses Google gives in order to successfully solve this problem. Please update to the leanest version of the Backup plugin as soon as it is available and post the relevant log entries here.

    Again, I am very grateful for your feedback and help.

    First of all, I need to thank you for this awesome plugin.

    Here is my query:
    I have tried to backup using Manual Backup URL, but it is not working, is there any solution for that ?

    Hi Bharath,

    Did you successfully authorize your Google Account on the Backup plugin’s settings page?

    If so, can you please paste the contents of the wp-content/backup/backup.log file here?

    I re-installed the plugin and updated it to 1.1 version. Its working fine now and thanks again for such an awesome plugin.

    I also wrote an article on Backup plugin Backup WordPress Blog to Google Drive

    Cheers
    Bharath

    I’m glad to hear that!

    Thanks for the quick feedback hel.io – here is my follow up:

    1) I’ve updated to the latest version and the time’s appear to be a bit mixed up. For example:

    I select ‘Never’ and it says “Next scheduled backup: Jun 20, 2012 at 22:46:43” (I’m assuming this should correspond to Monthly)

    I select ‘Daily’ ‘Weekly’ and ‘Monthly’ and it says “Next scheduled backup:
    May 21, 2012 at 22:48:30″ (this is scheduled for 3 minutes time!)

    Not sure if this is just on my blog, but it seems a bit peculiar! As when I re-load the ‘Backup’ page, the correct time corresponds to the time period I selected. Perhaps this is just an issue of what is loaded in the “Next scheduled backup:” section?

    2) I think it would be excellent to have that option, as to store even 3 backups on a webserver could be quite resource intensive – therefore the option for just Google Drive (or even to store just manually on the server) would be a useful addition imo.

    3) I have the ‘Backup’ plugin installed on 3 blogs, and the only message in the error log that I am getting is as below (this is all on the new version):

    2012-05-21 22:54:19 NOTICE Attempting to upload archive to Google Drive
    2012-05-21 22:54:20 ERROR Failed to upload archive to Google Drive!

    Thanks again for supporting your plugin and assisting 🙂

    Cheers,

    Lee

    I just tried the plugin and I am getting two different failures when I try to manually backup my site via the /backup URL:

    1) Permission denied on error_log() calls (L779), my entire directory structure is 755 so I am not sure why your plugin is barfing on writing out backup.log

    2) Warning: Cannot modify header information – headers already sent by on <path to backup.php> on 268

    The plug has authorized correctly with Google API Gdrive subsytem. The client ID is correct as well as the folder ID.

    I am not sure why the function error_log is failing. Again all directories are 755 (wp-content/plugins/backup) yet it won’t write out backup.log.

    What am I doing wrong?

    @leestewie

    1) No matter what frequency you select, the plugin schedules the first backup for the current date and time, and assuming that the 3 minute difference you’re seing is the difference between the server and your computer I would say it functions correctly. I did have to fix the plugin for ‘never’ though.

    2) I have added a new field on the settings page where you can enter how many backups to be stored locally. You can obviously enter in 0 for none.

    3) I think I am close to nailing it. Update to version 1.1.2 and paste the relevant log entries here.

    @pisymbol

    You’re number 2 issue is related to number 1 so we should figure out why error_log can’t write to the file.

    Can you confirm that wp-content/backup/backup.log has been created and contains “#Fields: date time type message file line”?

    I accidentally broke the plugin with version 1.1.2 so please update to 1.1.3.

    Hi again hel.io

    Just updated to 1.1.3 and it’s really helped solve some of those problems I was having, and I especially like the new feature (tested locally and working great!)

    I still have problems on all 3 of my blogs though, with sending to Google Drive. The error message is now:

    2012-05-23 21:26:24 NOTICE Attempting to upload archive to Google Drive
    2012-05-23 21:26:24 ERROR Bad response: HTTP/1.1 400 Bad Request /home/theblogg/public_html/leestewie/wp-content/plugins/backup/backup.php 422
    2012-05-23 21:26:24 ERROR Failed to upload archive to Google Drive

    Let me know if you need any further info.

    Cheers,

    Lee

    We are on the right track. So Google sais we’re not making the request right. Let’s see what the request header looks like:

    Update to 1.1.4 and again paste the log entries here.

    Oh, there’s one thing you need to remember. When pasting the log this time there should be a token in there which you do not want to make public (anyone with this token would be able to do anything on your Google Drive).

    The token should be a long random string just after “Authorization: Bearer “. Just tell me if the token is there and tell me the length of it but don’t paste it.

    Here’s the log:

    2012-05-24 22:29:03 NOTICE Attempting to upload archive to Google Drive
    2012-05-24 22:29:03 ERROR Bad response: HTTP/1.1 400 Bad Request. Request header: Authorization: Bearer *token removed*; Content-Length: 281; Content-Type: application/atom+xml; X-Upload-Content-Type: application/zip; X-Upload-Content-Length: 8796902; GData-Version: 3.0 /home/theblogg/public_html/leestewie/wp-content/plugins/backup/backup.php 422
    2012-05-24 22:29:03 ERROR Failed to upload archive to Google Drive!

    Therefore, yes, the token was there (I’ve hidden it in the above) and it was 60 characters.

    Let me know if there’s any further info you require.

    Cheers,

    Lee

Viewing 15 replies - 1 through 15 (of 46 total)
  • The topic ‘[Resolved] Backup Plugin Error’ is closed to new replies.