Support » Plugin: UpdraftPlus WordPress Backup Plugin » Backup Fails (SSL certificate problem?)

  • Resolved neoikon


    I am giving this plugin another shot after never getting it to work.

    I am using Google Drive as my offsite location. I went through all the setup as requested and filled out the Google Drive ID, Secret, Folder Id, Redirect URI, and authenticated (I get the “You appear to be already authenticated” message).

    I run the backup and receive an email. Toward the bottom of the email I see:

    Mon, 07 Jan 2013 19:22:53 +0000 Google Drive error when requesting access token
    Mon, 07 Jan 2013 19:22:53 +0000 Error message: SSL certificate problem, verify that the CA cert is OK. Details:
    error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed
    Mon, 07 Jan 2013 19:22:53 +0000 ERROR: Have not yet obtained an access token from Google (has the user authorised?)

    Also, when I click the “Test S3 Settings” I get the error, “Failure: No bucket details were given.” (perhaps this button isn’t supposed to appear when Google Drive is selected?)

    Also, the /wp-content/updraft directory is empty.

    I am using version 1.1.15 on WP 3.5

    Any help is greatly appreciated!


Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author David Anderson


    Thanks for the report…

    “Test S3 Settings” – yes, sorry, that should only show if you’ve chosen Amazon S3. Fixed now (1.1.16).

    For the SSL error, that’s coming from your (or the web hosting company’s) PHP/Curl installation. You’ll need to fix it yourself in your PHP/Curl install, or ask them to if it’s a web hosting company.

    Plugin Author David Anderson


    The other alternative is that indeed Google was serving up a faulty SSL certificate, which also can’t be ruled out. But UpdraftPlus (via the WordPress HTTP functions) is doing what it’s meant to there, verifying the connection.

    Thank you for the reply.

    My host is GoDaddy. Can you give me some more information on by the “PHP/Curl install”? I would think they would have the necessary settings, but maybe it’s something on my end I need to upgrade? I can’t be the only person who is hosted by GoDaddy and is communicating with Google.

    The only solutions I’ve found were to turn off the certificate check, which sounds like the wrong answer. (like fixing the check engine light by putting a sticker over it)

    I realize that it’s a bit outside the context of your plug-in (that it’s doing what it’s supposed to, as you mention), but I appreciate any help. Thanks!

    (I’m continuing to dig myself)

    Plugin Author David Anderson


    UpdraftPlus uses the WordPress HTTP libraries to perform its HTTP operations on Google Drive – specifically, the functions wp_remote_get and wp_remote_post. Those functions can use different PHP functions depending on what your PHP setup has available; curl is the default, I think (I could be wrong). But whatever is being used, has settings for the certificate authority files (cafiles) which are used to check the validity of SSL certificates (such as those provided by Google Drive). Either Google Drive temporarily showed you a wrong certificate, or your local configuration is wrong. It’s impossible to say which from this end, but I’m afraid I can’t give any more assistance as free support. (I fix a few UpdraftPlus tickets every day, and the lifetime of UpdraftPlus has seen 15,000 downloads and a total of $30 of donations, so it’s just not economic for me to do deep debugging of things that aren’t UD bugs).

    As a software developer myself and small business owner, I very much understand and appreciate the help.

    If I find a solution, I’ll let you know so perhaps it will help you and your future users.

    Plugin Author David Anderson


    Thank you, appreciated!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Backup Fails (SSL certificate problem?)’ is closed to new replies.