Support » Plugin: CYAN Backup » Backup Failed

  • Resolved clart

    (@clart)


    The backup runs on schedule but fails.
    I tried it several times manually and it always fails when creating the zip file around 11Mb in size. Heres the screen message:

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    Backup failed!

    Please advise.
    Thank you.

    https://wordpress.org/plugins/cyan-backup/

Viewing 15 replies - 1 through 15 (of 76 total)
  • Plugin Author Greg Ross

    (@gregross)

    Make sure your script execution time is set high enough in php.ini.

    Also make sure you have enough free disk space to create the zip file.

    You can also look at the PHP error log to see if any errors are recorded.

    I have plenty of free disk space available. I got to 9 failed backups, incomplete zip files of 11Mb and 9 directories full of site copy before I deleted the lot to try again.

    I am on shared hosting, I cannot see the PHP error log.

    What value should be script execution time?

    Plugin Author Greg Ross

    (@gregross)

    Depends on your host, size of your site, etc.

    Try increasing it (maybe double) and see if the backup get’s farther along.

    I tried increasing it in php.ini and wp-config.php and made no difference : set_time_limit(120);

    I excluded plugins directory and it worked fine, zip file is 37 Mb.

    I exclude most everything else except plugins dir and it fails.
    Something in plugins dir is causing it to fail.

    Also, there is bug : when it fails, cannot do another backup because of status, go to options and tick box to clear active backup status and update options. Then click Backups to try again, but after a few secs, the button disable, animation spinning, percent indicator back to the point previously where it failed and shows message “Archiving SQL Dump…”. This will not go away until go into the backup directory and manually delete the files left over by the failed backup attempt. When they are deleted and click Backup to try again, all is ok.

    Maybe there should be a button to delete the files when it fails ?

    Plugin Author Greg Ross

    (@gregross)

    Sounds like there is a plugin that has locked a file open and the backup code can’t get to it.

    If you could exclude each plugin directory one at a time and find out which one it is I can probably figure out what’s wrong.

    I’ll look in to adding an option to flush the temporary files as well.

    Thanks.

    I will check by excluding each one in turn, will take a while..

    I put extra button to update near top of page because tedious having to scroll down page to press update after changing just an exclusion.

    I edited page-options.php like this;

    ('Add WP-Includes Dir', $this->textdomain);?>" onClick="excluded.value = jQuery.trim( excluded.value ) + '\n<?php echo addslashes($this->chg_directory_separator($abspath . "wp-includes/", FALSE) )?>';"> 
    					</td>
    				</tr>
    <!-- extra button start here -->
    <tr><td><p style="margin-top:1em;"><input type="submit" name="options_update" class="button-primary" value="<?php _e('Update Options', $this->textdomain);?>" class="button" /></p></td>
    </tr>
    <!-- extra button end here -->
    			</tbody>
    		</table>
    
    		<h3><?php _e('Log Options', $this->textdomain);?></h3>

    [Moderator Note: Please post code & markup between backticks or use the code button. Your posted code may now have been permanently damaged by the forum’s parser.]

    Is there a quick way to delete the backup directory structure from failed backup ?
    It takes ages in FileZilla.

    Plugin Author Greg Ross

    (@gregross)

    Depends on your hosting provider, if you have shell access or a web based file manager there may be. If you only have FTP/FTPS then no.

    Though you could exclude all the subdirs to begin with and then start removing them one at a time so you don’t have a failed backup until you find the offending plugin.

    Have noticed a couple of things, maybe bugs ?

    The ‘failed’ message pops up very briefly a few times whilst backup is running and copying files. Its only for a split second and does not stop the process. This happens following a backup fail, clear status, update and try backup again.

    Also, after changing / updating options and click on Backups in the menu, sometimes the animation and message kicks in by itself so it looks like it started doing a backup, it quickly jumps to Archiving SQL Dump… with about 75% indicator and just sits there forever. ‘Backup Now!’ button is disabled so have to click options again and then update again but the same thing happens again until status.log is deleted.

    Something really weird happening with regard to plugins directory;
    Complete plugins dir excluded – backup completes ok
    All individual plugins subdirs excluded – backup completes ok
    Include any one of the plugins subdirs – backup fails

    I have tried it with different ones included, rest excluded and backup fails every time.

    I cannot think what else to try, any ideas ?

    Plugin Author Greg Ross

    (@gregross)

    Check the permissions on both the plugin top level directory and the plugin directories, are they different?

    Plugin Author Greg Ross

    (@gregross)

    Also check to see if there are any files in the root plugins directory that could be causing an issue.

    root plugins dir had .DS_Store in it, deleted that but made no diff.
    plugin top level directory is 755
    checked all the plugin dirs, they were 755 except for;
    s2member-files : 705
    s2member-logs : 705

    First I changed these to 755 recursive, tried again – backup failed
    Then I removed s2member completly as I dont use it, tried again – backup failed.
    Excluded plugins dir, tried again – backup completed ok
    Included plugins dir, tried again – backup failed

    It always seems to fail at same place, percent bar about 75% and message ‘Archiving SQL Dump..”
    When it fails it had that message showing for a little while.
    Is it possible to get a debug output to see what its doing when that message is showing ?

    Plugin Author Greg Ross

    (@gregross)

    The backup log file pretty much records everything that is happening, what are the last few lines in it?

    Ok, I included plugins dir, ran backup – it failed.
    The temp zip file is about 11Mb in size (as usual).
    The log file is 2Mb size, it contains all the paths and files including all the plugins. It all looks correct.

    Here are the last few lines of the log file;

    [2014-03-06 18:21:07] Archiving /homepages/35/d30352212/htdocs/winton/images/stories…
    [2014-03-06 18:21:07] Archiving /homepages/35/d30352212/htdocs/winton/images/stories/general/bowling_01.jpg…
    [2014-03-06 18:21:07] Archiving /homepages/35/d30352212/htdocs/winton/images/stories/general/bowling_02.jpg…
    [2014-03-06 18:21:07] Archiving /homepages/35/d30352212/htdocs/winton/images/stories/general/games_room_01.jpg…
    [2014-03-06 18:21:07] Archiving /homepages/35/d30352212/htdocs/winton/images/stories/general/lounge_01.jpg…
    [2014-03-06 18:21:07] Archiving /homepages/35/d30352212/htdocs/winton/images/stories/general/lounge_02.jpg…
    [2014-03-06 18:21:07] Archiving /homepages/35/d30352212/htdocs/winton/default.html…
    [2014-03-06 18:21:07] Archiving /homepages/35/d30352212/htdocs/winton/new.php…
    [2014-03-06 18:21:07] Archiving /homepages/35/d30352212/htdocs/winton/index.php…
    [2014-03-06 18:21:07] Archiving /homepages/35/d30352212/htdocs/winton/backup…
    [2014-03-06 18:21:07] Archiving /homepages/35/d30352212/htdocs/winton/wp-phpinfo.php…
    [2014-03-06 18:21:07] Archiving /homepages/35/d30352212/htdocs/winton/makezip.php…

    Plugin Author Greg Ross

    (@gregross)

    Looks ok, I’m just about to push out V1.6.2 which includes some more logging for errors. Once that is up give it a try and see if there are any errors listed.

Viewing 15 replies - 1 through 15 (of 76 total)
  • The topic ‘Backup Failed’ is closed to new replies.