WordPress.org

Forums

HMS Testimonials
[resolved] backslash issue (9 posts)

  1. kalmarnet
    Member
    Posted 1 year ago #

    Excellent plugin, thank you. All testimonials, whether submitted through the web form or the backend are showing a backslash before apostrophes:
    Ex:
    I\'m an 86 year old woman who\'s had

    http://wordpress.org/plugins/hms-testimonials/

  2. Jeff K
    Member
    Plugin Author

    Posted 1 year ago #

    Hey kalmarnet,

    I am looking into this. What version of the plugin are you using?

  3. kalmarnet
    Member
    Posted 1 year ago #

    Awesome, thank you for speedy reply. Version 2.1.7.

  4. Jeff K
    Member
    Plugin Author

    Posted 1 year ago #

    I see where the web form would not escape remove the the backslashes but the backend should have been doing it.

    Can you change the testimonial in the backend to

    I'm an 86 year old woman who's had

    and save it to see if the backslashes are gone.?

  5. kalmarnet
    Member
    Posted 1 year ago #

    Yes, I can fix it. Here's the weird part, if I create testimonial in the backend but leave the Source of Testimonial blank so that it throws an error, the testimonial text gets the backslash escape character on the apostrophes.

  6. Jeff K
    Member
    Plugin Author

    Posted 1 year ago #

    Fixing that as we speak. I will be pushing an update in the next 5 - 10 minutes fixing these issues.

  7. Jeff K
    Member
    Plugin Author

    Posted 1 year ago #

    v.2.1.8 is now out that should fix these issues.

    Thanks for letting me know of this bug.

  8. kalmarnet
    Member
    Posted 1 year ago #

    Wow, I wish you authored all my plugins!

  9. Jeff K
    Member
    Plugin Author

    Posted 1 year ago #

    :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • HMS Testimonials
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.