Support » Themes and Templates » backgroung image/color on pages does not work

backgroung image/color on pages does not work

  • Hello !
    when i do my pages, the backgroung color does not work seems that it can only be changed on the cms, problem is that i don’t want to change it for all content but just one page.

    I tryed to put a background color, and it looks like the content html is not in the page.. difficult to explain, the best is to see :

    i’m used to do that on wordpress, and that’s the first time i have a problem … as if it wasn’t possible to put background images..

    can you help ? cause i really don’t see what is the source of the problem..

Viewing 15 replies - 1 through 15 (of 18 total)
  • Theme Author Caroline Moore


    You probably need to target the page specifically using its ID. So, if your page has an ID of 1234, you could target its background color in your child theme or custom CSS plugin like so:

    body.page-id-1234 {
      background-color: #333 !important; /* Changing to the color value you want */
      background-image: url(/path/to/your/img.png) !important;

    If that’s not the issue, can you explain the problem more clearly, or post the styles you’re using to change the background color on that page?

    What I see on that page is a div called #apDivchou whose position is set to absolute, therefore .entry-content (the surrounding div that contains all the post content) cannot contain it, which is why the post wrapper ends abruptly underneath your content. Setting that div to position: relative will help, but might affect the other content around it depending on what you’re trying to do.

    it is not working… my page ID is it what’s written in my url ?
    http://www.leopoldineleblog.com/?page_id=39 , so “body.page_id=39” ?

    for my div, it’s not the absolute position causing the problem, on my other pages, it perfectly work !

    and for my css, i left it in my html of each page (i don’t know if i can put it on the child css or create an other so i left it for the moment, until each page is ok)

    so there is my html code:
    [HTML code unnecessary if you’ve linked the website]
    also the cs of the theme seems to mess up with the code i write, i don’t know why, for padding, for font-size.. what work on dreamweaver is not working when i put it on wordpress…

    i don’t know how to explain more specifically… i try to work with tables in % because it seems that it’s the only way to have it working with mobile..

    i’m lost… and i’m sorry if it’s over free support, tell me and i’ll go find help somewhere else..$$$$$$$

    i saw that if i put my css style in the style.css it works.. but i stile have the problem with my background :/

    ok, is there a possibility to put one image on the bockground for computer version and one for mobile version ? on the them style.css i guess ? but how ? i’m sorry for disturbing 🙁

    the code you gave me is not recodnize as a css style .. tells that it’s not correct.. i put :
    body.page_id=39 {
    background-color: #333 !important; /* Changing to the color value you want */
    background-image: url(/path/to/your/img.png) !important;

    Moderator Andrew Nevins


    Forum moderator

    This bit you’ve used;


    Is wrong. It should be this;


    This bit (below)

    background-image: url(/path/to/your/img.png) !important;

    Should contain the path to your image.

    don’t read all of what i wrote it seems to work (don’t know waht i did)

    thank you Andrew ! i’ll try it that way

    it is not working, i don’t see my image appearing :/

    Moderator Andrew Nevins


    Forum moderator

    This image doesn’t exist

    Are you sure that’s the correct directory or file name?

    i corrected it thinking that might be the problem but stile not working (with the good url)

    Moderator Andrew Nevins


    Forum moderator

    I think it is working but it’s just really subtle. You’re talking about the background image that’s applying to the <body>, right? If so, here’s a comparison between it applied and not applied.

    Applied – [screenshot]
    Not applied – [screenshot]
    (ignore the toolbar)

    no i’m talking about the background in the body of my page.
    you are talking about the background of the entiere site.

    it is supose to look like that
    (i know it’s small i don’t know why)

    the curious thing is.. with the color it’s working and it get all the background (even the color on font that you were talking about)

    so i’m wondering.. is my background behing the white part my my text ??

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘backgroung image/color on pages does not work’ is closed to new replies.