Support » Plugin: Responsive Menu » Background scrolling in 3.1.17

  • Resolved plimfec

    (@plimfec)


    Hi @peter,

    Updating from version 3.1.14 to 3.1.17 I read in the changelog for 3.1.17: ‘Change approach to disabling background scrolling’, so I paid extra attention to it. My experience is that avoiding the background scrolling was slighty better in version 3.1.14.

    Test -> When I open the menu in 3.1.17, swipe down somewhere in the menu, and after doing this, do a swipe up (to go down in the opened menu), the background is scrolling down as well. Not as fast as the menu is, but the background is not stable.

    I didn’t remember this behaviour from the old version, so I went back to 3.1.14 to check this. And indeed, in 3.1.14, doing the same swipes, the background is solid as a rock.

    My testing device was an old iPhone 5, but that doesn’t matter for this issue, I suppose.

    Btw: it’s not just during these specific swipes that the background is a bit more unstable in my experience, but when randomly swiping up and down through the opened menu, there are multiple times the background is moving as well. This was not happening in old version 3.1.14 (except at the bottom of the menu, when still swiping down, but that’s not bothering me).

    Even though it’s not a very big issue, it’s a bit annoying, so I went back to 3.1.14 for now.

    I’m curious whether you can reproduce this behaviour? I’ll appreciate when you can take a look.

    Thanks very much in advance,
    Plimfec

Viewing 13 replies - 1 through 13 (of 13 total)
  • Peter Featherstone

    (@peterfeatherstone-1)

    Hey there,

    Yes it doesn’t work as well in iphones but is a massive improvement on all other devices.

    iPhone improvement is on my list of things to look at.

    Thanks for the heads up.

    Peter

    Well, that was quick! Thanks a lot.
    Happy to know it has your attention.

    Keep up the good work, I use your plugin with pleasure,
    Plimfec

    Peter Featherstone

    (@peterfeatherstone-1)

    Hey there,

    No problem, I’m glad you are enjoying the plugin!

    Peter

    Hello,
    Thank you for sharing an amazing plugin. I do love this plugin although I knew this plugin lately.

    I’ve installed 3.1.18 version, and I think I have the same problem. After the menu is opened on, whenever scrolling somewhere on the menu, the background page moves as well. The devices tested are S7 and S9. Could you take a look at this problem?

    Thank you in advance.

    Peter Featherstone

    (@peterfeatherstone-1)

    Hey @dasom38 ,

    Unfortunately you haven’t provided a website for me to look at so I don’t have anything to test.

    Please advise

    Peter

    oh, thanks for quick reply. You can see it below site although not completed yet:

    http://www.gaia4h.com

    Peter Featherstone

    (@peterfeatherstone-1)

    Hey there,

    You are right, it does still scroll. However the no scroll javascript file is not being included on your page so are you sure you have that option turned on as it doesn’t look like you do?

    In addition, have you cleared caches?

    Peter

    Thanks a lot. The problem was just because I was a beginner. As you said, I’ve just added no scroll script and it works good. Sorry for bothering you, and I appreciate you.

    Peter Featherstone

    (@peterfeatherstone-1)

    No problem, glad it’s ok now 🙂

    Hi, quick question (as it seems that I’ve the same issue). Where do I find the no scroll script / option? thanks!

    Peter Featherstone

    (@peterfeatherstone-1)

    Hey @dande82,

    It’s called Disable Background Scrolling.

    All the best

    Peter

    Hi @peterfeatherstone-1
    thanks!
    That’s a pro-feature, isn’t it?

    I guess I (also) have another problem. I’ll open a new thread.

    Davide

    Peter Featherstone

    (@peterfeatherstone-1)

    Hey Davide,

    That’s correct 🙂

    Peter

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Background scrolling in 3.1.17’ is closed to new replies.