Support » Fixing WordPress » Background Request Blocked

Viewing 12 replies - 1 through 12 (of 12 total)
  • Hello,

    I am also experiencing this same problem with one of our websites.

    Jayxcamps, it appears as if you are using the Divi theme. Our site that is also experiencing this ‘Background Request Blocked’ is also using the Divi theme. For our website in question, it is using Divi version 2.7.5 with WordPress 4.5.2

    This error only just started appearing this week (we noticed it today). We were in our site last week and we did not get this error.

    Does anyone know what changed to make this error appear?

    Also, we make many sites that use the Divi theme, and only one of our sites (that we have noticed) is giving us this error while our other sites with Divi are not.

    I too have just seen this error this morning. I am using Advanced Custom Fields and very few plugins as I tend to be leery of most. Am investigating now. I write my own themes so I doubt it’s related to a particular theme – i.e. “Divi” . Will post what I find. Very suspicious.

    I run Wordfence Security and this was the only update I have on my install since I noticed this issue. Since the error was only being thrown on a single page, first thing I checked for was code that looked “suspicious” in my HTML fields. Low and behold, I found I had a youtube iframe embedded in the html I had copy and pasted. Removing the iframe code from the text field stopped the error. I suspect, the blocking message has something to do with particular escape characters being nested in HTML as they may be malicious.

    Will keep an eye on this thread though.

    Showing some love from New Orleans

    I’m getting the same ‘Background Request Blocked’ message while trying to update sidebar widgets with new ad code. Clicking the ‘Whitelist’ button does nothing. I’m also unable to delete widgets that contains ad code.

    I don’t want to uninstall Wordfence, but I need to update my ads. Does anyone have any idea what I can disable in Wordfence settings so I can update my ads??

    @theevent Your best option is to manually place your ad code in your theme template. You don’t want to disable anything in Wordfence that is intended to protect you from attacks. I would temporarily disable Wordfence and clean up that mess – scripts in widgets and all that. <smile> Putting code in your template files is a good idea for other reasons too, If you don’t know how to edit a template file – I might be able to give you a few pointers. It’s not that difficult.

    Up late in New Orleans

    Finally looked into my log files. The error was throw to protect against cross browser scripting. Hence, the reason the Youtube iframe triggered the message.

    I must say, the whole thing did smell like a hacker.

    Holding my nose in New Orleans

    Hi all,

    This dialog box was introduced in Wordfence 6.1.8 — it appears when an ajax request is blocked in the background, and in prior versions, it sometimes wasn’t clear when something was blocked in the background. (The box only appears for logged-in admins.)

    If you see it when working on your site, it should be safe to whitelist the blocked action, but if you see it when clicking a link sent to you by someone else, or when you’re not trying to make changes to your site, it may be suspicious.

    If you have this happen in more than one place on your site, it may be easier to use the firewall’s Learning Mode temporarily, described here:
    How to use Learning Mode

    If anyone still has trouble and needs more details, please make a new post using the form at the bottom of the Wordfence forum here, with the details of the issue.

    @theevent: Your site may have a conflict with a plugin or a theme that is stopping Whitelisting from working. Learning Mode may work for you still, but you can also get more help on the Wordfence forum (linked above.)

    Thanks!

    -Matt R

    Desactiva el Plugin Wordfense y quedará resuelto.

    Disable the Plugin Wordfense, and will be solved.

    Thank you Matt. Learning Mode was the advice Thrive gave too.

    It’s a pretty sad day when we have to disable a plugin because we are working in admin. This error happens to me in galleries mainly, both Envira and Nexgen. I couldn’t even update the photocrati updates because of this error until I disabled wordfence. With Envira, I couldn’t use images I’d already uploaded to the Media library. I had to actually reupload the images to get them to show up. I get it, it’s probably a plugin conflict, but we should be able to disable this feature in Wordfence without having to disable wordfence itself. I do not have the time or patience to deal with forums and hoping an answer will come, nor do I have the time to track something that may or may not be caused by a different plugin, when one plugin seems to be causing the issue itself. I’ve installed a different firewall at this point, and guess what.. it’s working fine.. sadly, wordfence will just become a memory for me. I was very happy with Wordfence, sadly, you should have thought of those of us who use it, whether it’s the free or pro version of the software.

    Hi Seamstobesew,
    What new firewall are you using? I had the same error, trying to add an Amazon Smile Code to a sidebar widget. Wordfence is a plugin.
    Thank you for your help…if you are still there 10 months later.

    I use All In One WP Security & Firewall and
    Anti-Malware Security and Brute-Force Firewall

    However I did finally remove Envira as I no longer need it, I have combined all my photo stuff into one gallery plugin.

    • This reply was modified 3 years, 5 months ago by seamstobesew.
Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Background Request Blocked’ is closed to new replies.