Support » Plugins and Hacks » Background Manager & Cache Plugin

Background Manager & Cache Plugin

  • Thank you for a great plugin!

    I have experimented with WP Super Cache and Quick Cache and it seems both do something to make the images stop rotating.

    In their settings they do allow for things to exclude from caching.

    Have you tested Background Manager with a caching plugin? Can you tell me what I should do so that I can use a caching plugin and Background Manager?

    Thank you!


Viewing 11 replies - 1 through 11 (of 11 total)
  • I too have the same issue. Any support would be welcomed!

    It appears to be the Minify option when set to auto.

    I also share many thanks to you for this great tool!

    Plugin Author myatu



    Background Manager has been tested with WP Super Cache, W3 Total Cache as well as the third party service CloudFlare (as used on the BGM Demo Site).

    However, the Minify option in W3TC as well as some other minify plugins do not always follow the load order of JavaScript, which may cause issues. Background Manager already uses minified JavaScript (except in WordPress Debug Mode).

    Also keep in mind that garbage collection will need to be done at 12 hours or less, due to the default setting of NONCE lifetimes within WordPress (24 hours, set in 12-hour blocks – more details here: http://myatus.com/p/wordpress-caching-and-nonce-lifespan/ ).

    Background Manager will also automatically utilize PHP APC, if it is installed, which can increase its performance. You can check if it is enabled by going to the main Settings page (Appearance -> Background) and clicking the Debug link at the bottom of said page. You would see:

    Pf4wp APC Enabled:	Yes

    Further improvements based on APC and Memcache(d) are on its way.

    Hi Mike,

    thanks for your great plugin. I also have the same problems that bg-images are not rotating when W3-total-cache is active. When I’m logged in it does (because logged in users get non-cached pages) but when I’m logged out it’s always (and really always) the same background image I’m getting on a certain page. I’m using w3-total-cache without minify, Cloudflare or CDN.
    My site is http://www.janpeeters.nl

    Do you have an idea?

    Thanks Jan

    Plugin Author myatu


    Hallo Jan,

    What is the setting you have used for ‘Select an image’? I.e., ‘On a page (re)load’

    Yes that’s the one! 🙂

    Plugin Author myatu


    Ah, right. That would be an incompatibility issue in this case, as the initial image is chosen using PHP (and thus gets cached by W3 Total Cache).

    Although it is progressing slowly, mainly due to the fact I can only work on the plugin during spare time, I do intend to provide better support for caching plugins. But in this instance, I can only suggest changing that setting to every ‘X’ seconds — after the initial image, JavaScript will take over and can deal with random images without caching issues. Sorry about that!

    Hi Mike,

    well great that your putting spare time in it. And thanks for explaining. I’ll switch to the other setting for now en look forwards (don’t feel rushed ;-)) to your changes. Thanks

    I have had my background images set to every 10 seconds, but still they get cached and end up stopping. 🙁

    Plugin Author myatu


    @zerogravitygraphics – It might be unrelated. The caching plugin have many different options, which in turn can affect the plugin in a different way.

    No worries. The caching plugin gets deactivated because I can’t live without Background Manager! 🙂

    Plugin Author myatu


    Thank you 🙂

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Background Manager & Cache Plugin’ is closed to new replies.