Support » Theme: Pinnacle » Background images are displayed in a “zoomed” size

  • mirageborska

    (@mirageborska)


    Hello,

    So i have these banner blocks (Site origin Editor widgets) with a background images. Images are set like this in custom css:

    background-attachment: fixed;
    height: 650px;
    background-size: cover;

    The files are originally even higher. The problem is that on the page they are not shown in the full width. They are zoomed in and cropped. I would like them to be shown in full width (and be cropped from top/bottom instead). When I change “Background-attachemnt” to nothing (delete it) then the photo shows correctly.

    What’s also strange I noticed that when opening “inspect” in chrome on the bottom of the page, it influences the size of the photo. When changing size of inspect, the size of background image was changing.

    Do you maybe know how to fix this? I really like this “fixed” effect but

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Kevin

    (@jx-3p)

    Hey,

    The images are set to be parallax. This by default will zoom in on the images because that’s how parallax works.

    You can disable this in the row design under “Background Image Style.”

    Does that work for you?

    -Kevin

    mirageborska

    (@mirageborska)

    Hi Kevin,

    When I edit page I have row “Backround IMgae display” and it’s set up to Cover, as the Parallax settign was not working as I wanted (zooming even more). So what I did i set them up as Cover, but then in custom CSS add:

    background-attachment: fixed;
    height: 650px;
    background-size: cover;

    Is there any way to control the zoom of parallax feature? I would just like the photo to be shown in it’s full width. I especially made the images higher then the div, so that there is enough to have that scrolling effect, even when the photo is full width. Should I maybe made the images even higher in original?

    Kevin

    (@jx-3p)

    You can’t show the whole image like with the other options with parallax. That’s not how it works unfortunately.

    The only way you can really control the zoom is by using larger images. If you use something that’s like 2500px wide then it will zoom in less than a picture that’s 1200.

    I’m not sure what you mean by “made the images even higher.” Are you referring to how you’ve cropped the images?

    -Kevin

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Background images are displayed in a “zoomed” size’ is closed to new replies.