Support » Plugin: WP Super Cache » Background images and Plug-ins not working with CDN enabled

  • My website is – right now, I am running Wp-Super-cache with the CDN disabled. When it is enabled, the background image (the butterflies) do not show for some reason. Additionally, scheduled posting won’t work and WP-ReportPost doesn’t work. Also, with the CDN enabled, the bar at the top of the site for logged in admins does not appear.

Viewing 14 replies - 1 through 14 (of 14 total)
  • Oh – I am using Amazon Cloudfront for CDN

    Can someone please help me with this?

    Obviously, the developer doesn’t read this thread and the link in the dashboard to his website is generating a 404 error. I guess I will have no choice but to take my business elsewhere.

    Plugin Author Donncha O Caoimh


    You probably need to check that the files are on your CDN and the urls in your pages match those CDN urls? I’m not sure about the admin bar, and the scheduled post problem could be because there’s no PHP getting executed on your site now that it’s all cached.

    If that reportpost plugin depends on PHP executing on every page served then it won’t work. There’s a FAQ about that but with different plugins. Same idea however.

    Yes – I did check that – and the URLS matched. It won’t pull down background images. As long as the CDN is disabled, the admin bar in the new WordPress works fine. However, if it is enabled, it doesn’t. The Caching is working ok and doesn’t seem to interfere with either the background images or the plugins – it’s only when CDN is enabled. I have made sure that the button to exclude php from being re-written is checked.

    Also, I apologize for my tone. I’ve been trying to get help with this for days and was getting frustrated.

    Plugin Author Donncha O Caoimh


    Unfortunately it appears Cloudfront doesn’t support origin pull, the technique the plugin relies on to move files to the CDN. You’ll have to copy all the files there manually.

    That includes images, css and maybe js files.

    Cloudfront actually support a “custom origin” and as such can do origin pull. Just grab W3 Total Cache to take advanced of feature complete CDN implementations.

    I had a problem with w3 Total Cache serving my custom 404 to some visitors sometimes for some reason. I never was able to figure out what the problem was and uninstalled it.

    Would you like some help then? it sounds like an order of operations issue with your installation.

    I would love some help with it!

    I had submitted a support request through the dashboard, and never heard back from anyone with w3 Total Cache – which is why I switched to a different caching system. If you are still willing to help me, I would consider switching back. I was having several problems with it.

    I guess I will have no choice but to take my business elsewhere.

    That’s really funny!

    It’s true that Fredrick appears to be a very busy boy, and when he does visit here it’s usually a marathon. It would be nice if he had time to dedicate all of his time to this plugin and those of us that use it for FREE, but that’s just not possible.

    This plugin is extremely complex and does so much more than any other caching plugin. It’s not perfect, but a work in progress. Many of the problems users experience are due to improper settings and implementation, but there are some issues with the current release as well as the development version that need attention, and I look forward to Frederick’s getting to these much like a kid waiting for Santa!

    Free? I offered to pay for the support through the support tab – so yeah – take my business elsewhere. Glad you think it’s so funny. Besides – that was posted 4 months ago and I still haven’t gotten any help with it. Additionally, that wasn’t posted to Fred Townes – I didn’t add the tag for his program – somebody else did.

    I apologize for the slow response time. I’m working on organizing a team to assist with support.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Background images and Plug-ins not working with CDN enabled’ is closed to new replies.