WordPress.org

Support

Support » How-To and Troubleshooting » Background image ??

Background image ??

  • well, my problem is that i have an background image in the header that shows well in Iexplorer, but in Opera, Mozilla and Netscape it just disapears..
    I’m kind of a newbee so if anyone can help..
    Here is the code for the header:
    background: url('wp-images/Logo.gif') #BB5710 no-repeat
    left top;
    float: left;
    padding-bottom: 0px;
    margin: 0px;
    width: 723px;
    padding-top: 0px;
    height: 100px;
    text-align: left;

    Thanks..

Viewing 8 replies - 1 through 8 (of 8 total)
  • W3C CSS recommendation says this about the background property:
    Value: <background-color> || <background-image> || <background-repeat> || <background-attachment> || <background-position>
    I guess if you swap the background color and the image-url around it will work in the other, more standards compliant, browsers.
    Let me know if that was indeed the problem… it’s one of the reasons I never use these compound properties but specify everything apart.

    A url would really help us help you.

    But in shorthand, this should work:
    background: #BB5710 url('wp-images/Logo.gif') no-repeat left top;
    float: left;
    padding-bottom: 0px;
    margin: 0px;
    width: 723px;
    padding-top: 0px;
    height: 100px;
    text-align: left;

    The order indeed is quite important.

    Just back from the see, and the answer is already here..
    Thanks guys, everything works fine now 🙂
    Never new that the order of the properties was so importent..
    Greetings,
    Franky.

    I placed a small graphic to divide the main content from the sidebar in the image folder of the fresh theme. I’m doing something wrong but can’t put my finger on it.

    Here’s the site http://www.sbe38.org and here’s the code.

    #content {
    float: left;
    width: 560px;
    height: 100%;
    background: #fff; url(images/border.gif) repeat-y top right;

    I’ve cleared the cache, but no graphic is showing.

    help is welcome

    thanks

    don (el paso)

    Sorry for asking again…. I can’t seem to get this right. I would like to use an image to make a border between the main body and sidebar.

    I placed this code and variations in the style sheet.

    background: transparent url(images/border.gif) repeat-y right top;
    also tried.
    background: #fff url(images/border.gif) repeat -y right top;

    I have placed the code in the:
    #body
    #content
    .pages

    Where should I place the code? Should I post the style sheet to get help? I am using the fresh theme by LEMONed

    don (el paso)

    This seems to work on your site for me (in the #content declaration):

    background: #fff url(images/border.gif) repeat-y right;

    Thanks Kafkaesqui,

    I am having limited success. The graphic shows at the bottom of the page beside the “older entries” blue bar. I will work on getting it to tile vertically the whold page (top nav to bottom blue section).

    don (el paso)

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Background image ??’ is closed to new replies.
Skip to toolbar