WordPress.org

Forums

Stitch
Background image issues (5 posts)

  1. gimbha
    Member
    Posted 2 years ago #

    Hey there,

    I have tried adding an image to use as the background for the content-half of the theme. The image is large, and I don't want it tiled. It only over displays as a very small image in the centre of the top of the page... I can't find a way to get it to be full-sizad.

    Can you help me?

  2. WPyogi
    Forum Moderator
    Posted 2 years ago #

    You'll need to post a link to your site for help with CSS questions.

  3. zlajaa1
    Member
    Posted 2 years ago #

    By default css background-image attribute is set to repeat image on x and y, and background-position is set to top-left side. You will need to overwrite these settings.

    .some_class{
    background-image: url('location of image'); //this sets image
    background-repeat: no-repeat; //This set no repeat to bg image
    background-position: center top;// Set image on top and center
    }

    If you need more help please provide us with a URL, and more specific explanation of problem.

  4. zlajaa1
    Member
    Posted 2 years ago #

    Sorry one explanation. The .some_class is usually body.

  5. gimbha
    Member
    Posted 2 years ago #

    Thank you so much for your support. Sorry I neglected to give a link to the site... you can find it at bellaelite.ca

    I haven't been able to fix this yet, I couldn't find .some_class anywhere in the code files...

    Another issue that has cropped up is that various browsers are not viewing the logo as I intend it to be viewed. I tweaked the code to insert my own logo image (it got messy but I managed to make it visually work on my browser). Any ideas for cleaning it up or getting it to translate better across other browsers would be deeply appreciated.

    Cheers, and thanks again!

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic

Tags