Support » Plugin: The Events Calendar Category Colors » Background Color Not Showing in Legend or Calendar

  • Resolved wpmjm

    (@wpmjm)


    I have selected the background colors and font colors for the category in the settings tab. However, when I view my calendar, the selected colors do not show up in the legend or in the calendar. In addition, if I select SuperPowers the category links in the legend are not active and cannot be clicked. If I disable SuperPowers I can click on the categories in the legend. With or without SuperPowers, the selected colors do not work. Can you advise what I may be doing wrong?

    Screenshot of Settings

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Andy Fragen

    (@afragen)

    It appears that the CSS file located in wp-content/uploads is displayed as a 404. That would indicate that something on your server is not allowing the CSS to load.

    wpmjm

    (@wpmjm)

    Thank you. That was exactly the problem.

    jpeirce

    (@jpeirce)

    I am having the same issue. I just changed everything on the site to work with our SSL certificated. Everything is now working except for the category colors not showing up. They were showing up before the change.

    I don’t see any .css document in the Uploads folder. What should I be looking for? I also don’t see a link to a category color css in the page source.

    Plugin Author Andy Fragen

    (@afragen)

    @jpeirce a URL to the calendar would help.

    jpeirce

    (@jpeirce)

    I did a bit more troubleshooting but still no luck. I have found the teccc_stylesheet in the uploads folder and it is being correctly called as https:// in the page header.

    The page is at: https://discoveryvoyages.com/rates-schedules/

    When I use Web Developer Tools to look at the code and styles, I can select the h2 a block level element that is usually colored: h2.tribe-events-list-event-title but it doesn’t have a background-color. The color doesn’t appear to be being overwritten or superceded by another css element. It seems like their is no category-specific selector that would trigger the background-color.

    Here is a sample of the css from the teccc_stylesheet:

    .tribe-events-category-3-day-classic-voyage h3.tribe-events-list-event-title,
    .tribe-events-shortcode .tribe-events-month table .type-tribe_events.tribe-events-category-3-day-classic-voyage,
    .tribe-events-list-widget li.tribe-events-category-3-day-classic-voyage h4,
    li.tribe-events-list-widget-events.tribe-events-category-3-day-classic-voyage h4,
    .events-archive.events-gridview #tribe-events-content table .type-tribe_events.tribe-events-category-3-day-classic-voyage,
    .teccc-legend .tribe-events-category-3-day-classic-voyage,
    .tribe-events-calendar .tribe-events-category-3-day-classic-voyage,
    #tribe-events-content .tribe-events-category-3-day-classic-voyage > .tribe-events-tooltip h3,
    .type-tribe_events.tribe-events-category-.tribe-events-category-3-day-classic-voyage h2,
    .tribe-events-category-3-day-classic-voyage > div.hentry.vevent > h3.entry-title,
    .tribe-events-mobile.tribe-events-category-3-day-classic-voyage h4
    {
    background-color: #7a209b;
    border-left: 5px solid #CFCFCF;
    border-right: 5px solid transparent;
    color: #fff;
    line-height: 1.4em;
    padding-left: 5px;
    padding-bottom: 2px;
    }

    Plugin Author Andy Fragen

    (@afragen)

    Can you click the Show legend in the settings. It helps me figure things out.

    In your example above the category would be 3-day-classic-voyage. Is that what you intend?

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Background Color Not Showing in Legend or Calendar’ is closed to new replies.