Support » Plugin: Sticky Menu, Sticky Header (or anything!) on Scroll » Background color is not displayed…

  • Hi there,

    first of all: Great Plugin. Almost everything works great on the default mode. However theere is one problem. The background becomes transparent. I already tried to solve the problem by inserting the folowing CSS:

    .element-is-not-sticky {
    background: #000000 !important;
    }

    .element-is-sticky {
    background: #000000 !important;
    }

    However that didn’t work…

    In Legacy mode and dynamic mode the background color works correctly, but there are a lot of other issues…

    How can I get the background color to work correctly on default mode?

    It would be awesome, if you could help me. Thanks in advance! 🙂

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hi, thanks for trying my plugin.

    From what I can see, the background is properly set on the item (in both sticky and non-sticky mode) but there’s a few other things going on here.

    First, it seems like the element is made hidden (using visibility: hidden). Second, the elements within the sticky element have a background color assigned to them, which is hiding the background color of the main element, so you might have to do something like:

    .element-is-not-sticky > div {
    	background-color: #000000;
    }

    Please let me know if that helps.

    Hi Mark,

    thanks for your response! Great that you offer support for your free Plugin.

    I removed the background color within the sticky element, but it still didn’t work. So I changed it back.

    What do you meant with the hidden visibility? Any ideas how to fix that?

    I discoverd that by resizing the browser window the background color suddenly gets visible… Does that help to fix the problem?

    I have absolutely no idea what could cause the problem… Any other ideas?

    It would be great if you could help me. Thanks in advance.

    Best Regards,
    Lukas

    Senff

    (@senff)

    Apologies for the late response. It looks like you have now disabled my plugin — did you find a different solution?

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Background color is not displayed…’ is closed to new replies.