WordPress.org

Forums

WordPress HTTPS (SSL)
[resolved] Backend redirects to 404 - Not Found (9 posts)

  1. I have a fully functional positive ssl cert installed. On our internal development site it works great on the front end and we have fixed all insecure content issues.

    However, when we enable force ssl for the WordPress dashboard we are immediately directed to a 404 not found in this format.

    http://www.domain.com/login/?redirect_to=https%3A%2F%2Fwww.domain.com%2Fwp-admin%2Fadmin.php%3Fpage%3Dwordpress-https&reauth=1

    We do use lighttpd instead of apache2.

    http://wordpress.org/extend/plugins/wordpress-https/

  2. Update: Seems that this plugin is not compatible with WP-LOGIN (http://wordpress.org/extend/plugins/wp-login/).

  3. Mike Ems
    Member
    Plugin Author

    Posted 2 years ago #

    Umm, what? If there is an incompatibility with another plugin, this is hardly resolved. Could you explain?

  4. When we enable force ssl for the WordPress backend we are immediately directed to a 404 not found in this format.

    http://www.domain.com/login/?redirect_to=https%3A%2F%2Fwww.domain.com%2Fwp-admin%2Fadmin.php%3Fpage%3Dwordpress-https&reauth=1.

    The WP-Login for some reason redirects to it's login page (domain.com/login) and results in a 404.

  5. Mike Ems
    Member
    Plugin Author

    Posted 2 years ago #

    So without WordPress HTTPS enabled, http://www.domain.com/login/ works fine. But, when enabled, it's a 404?

  6. Yes, that's correct -- http://www.domain.com/login/ tries to redirect to https://www.domain.com/login and then results in a 404.

  7. Mike Ems
    Member
    Plugin Author

    Posted 2 years ago #

    Okay, does https://www.domain.com/login work without the plugin?

  8. Yes, it does. Right now we have removed the WP-Login plugin and coded our own login form while using your plugin.

  9. Mike Ems
    Member
    Plugin Author

    Posted 2 years ago #

    Yeah, I don't know if it would be easy to get these to work together. As long as the login page URL doesn't change, everything should work fine with my plugin.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WordPress HTTPS (SSL)
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic