Support » Fixing WordPress » Backend not showing

  • Hi

    I’m trying to install a copy of my live wordpress site (crafty-stuff.com) on my local system, running xampp.

    Have downloaded wp-content and have a copy of the live database using “Bamboo Migration” plugin to switch out some urls too.

    So the site is working nice – all content seems to be showing up at http://localhost/Crafty-Stuff/ for me, but when I login into the backend “http://localhost/Crafty-Stuff/wp-login.php” I just get to my home page with a wordpress bar/taskbar on top, but with no way/link on it to get to the add posts and pages management backend area.

    Think I may have deleted some tables that I shouldn’t have before I imported the sql.zip.

    Any help?

Viewing 12 replies - 1 through 12 (of 12 total)
  • I think you can simply Download all the file from your file manager in Zip format. And simply Extract them in your Local Host .httpaccess folder.
    The difference is you have “Public.html in the file manager of your web server and here in local server, you have the httaccess folder.
    Make sure that you have created the same database name as your web server database. It should work then.

    Another way is,
    Simply install a WordPress site in your Local server. Then replace the downloaded file. Note that you have to extract your zip file and then replace (copy paste) the file in your local server WordPress/WP folder (of your httaccess).
    Firstly Replace the plugins. then replace the other folders one by one.

    Hope this will help the issues.
    Goodluck

    Stef

    (@serafinnyc)

    Post a picture of your local DB please. Specifically the Options table

    Hi Stef,

    There are several pages of info in the options table but the 1st is:

    http://crafty-stuff.com/wp-content/uploads/2019/05/DB1.jpg

    • This reply was modified 1 month, 3 weeks ago by  Franky616.
    • This reply was modified 1 month, 3 weeks ago by  Franky616.
    Stef

    (@serafinnyc)

    Ok great. Is your folder named exact as it is there? “Crazy-Stuff” caps and all?

    My professor would slap your cap fingers. No caps in urls. LOL

    The site folder in htdocs is Crafty-Stuff caps and all not “Crazy-Stuff”.

    • This reply was modified 1 month, 3 weeks ago by  Franky616.
    Stef

    (@serafinnyc)

    Make sure you don’t have any htaccess file in the folder and no permission restrictions on that.

    Can remove .htaccess but don’t know what to do about “no permission restrictions on that”.

    Did take a look at the Crafty-Stuff folder and it has a Read-only check

    • This reply was modified 1 month, 3 weeks ago by  Franky616.
    Stef

    (@serafinnyc)

    Great. Any luck?

    No luck, will change folder name and alter .sql file for no cap urls tomorrow – then inport it.

    will uncheck read-only and remove the .htaccess too

    Will let you know if things change

    Stef

    (@serafinnyc)

    These are the steps I take when installing locally.

    1.) Create Fresh WP folder ( not DB or anything unless needed. Use yours but make sure that you take out the config and htaccess)
    2.) Upload SQL to local database repository (if it’s huge I just add it to folder)
    2.) Configure new Config ( make sure DB name matches on config and root and root)
    3.) Make sure Prefixes match
    4.) Make sure folder matches URL localhost/whatever-name-of-folder
    5.) After SQL is loaded I change all the URLs
    6.) Sip a cold brew and call it a day. (i don’t drink but man it sounds good)

    • This reply was modified 1 month, 3 weeks ago by  Stef.

    No luck – but if I clear the database (drop all tables) and remove wp-config.php I can get to the back end OK after a fresh(to blank WordPress) install procedure

    So thinking my copy of the database is somehow wrong… for if I then drop the blank database tables from the clean blank wordpress and import the hosted site’s .sql(with altered urls) I again lose the backend

    Thanks by the way for your procedure – will maybe understand it fully one day 🙁

    • This reply was modified 1 month, 3 weeks ago by  Franky616.

    Got it working – had to separate all tables in the hosted db into single import files(one for each table), do a clean blank WordPress install, and drop then import each of the tables separately until I got a problem login into the backend.

    Something in wp_usermeta was the problem, so did an install of the hosted site’s full db, dropped the wp_usermeta and imported another version from a clean blank WordPress.

    Not yet capable of going through the wp_usermeta to see if I can work out the problem fully.

    Thanks for the help guys anyway 🙂

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.