Support » Networking WordPress » backend http to https random redirection

Viewing 9 replies - 1 through 9 (of 9 total)
  • Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    ๐Ÿณ๏ธโ€๐ŸŒˆ Plugin Review Team Rep

    There’s no redirect in your .htaccess righjt?

    Here is the .htaccess:

    # BEGIN W3TC Browser Cache
    <IfModule mod_deflate.c>
        <IfModule mod_headers.c>
            Header append Vary User-Agent env=!dont-vary
        </IfModule>
            AddOutputFilterByType DEFLATE text/css text/x-component application/x-javascript application/javascript text/javascript text/x-js text/html text/richtext image/svg+xml text/plain text/xsd text/xsl text/xml image/x-icon application/json
        <IfModule mod_mime.c>
            # DEFLATE by extension
            AddOutputFilter DEFLATE js css htm html xml
        </IfModule>
    </IfModule>
    # END W3TC Browser Cache
    
    AddHandler php5-script .php
    
    php_value memory_limit 300M
    php_value max_execution_time 0
    
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
    
    </IfModule>
    
    # END WordPress
    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    ๐Ÿณ๏ธโ€๐ŸŒˆ Plugin Review Team Rep

    Check on a different browser.

    Also delete all the cookies for that domain and log back in. See if that forces it around.

    I deleted cookies, temporary files, etc and tried it in different computers, browsers and operating systems and the final result is the same. It is still happening.
    I guess is something related to the theme, css, js… Sometimes the website doesn’t load properly…

    Do you know where I can check the errors of my template while loading?

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    ๐Ÿณ๏ธโ€๐ŸŒˆ Plugin Review Team Rep

    Turn on Debugging: https://codex.wordpress.org/Debugging_in_WordPress#WP_DEBUG

    Also I’d check the server error logs. Maybe a server setting is prompting the redirect.

    I will turn on the debugging feature soon. Before doing that I want to say that I have 3 more blogs under the same network and they have the same issue.
    While navigating through wp-admin, you get the message that says that the content isn’t secure and the SSL certificate doesn’t belong to current domain (because I’m getting redirected to https and i’m not using a certificate for my domain). Saying that, I guess there is a problem with the server of the hosting company. It’s a shared hosting. I’m planning to build a development environment to test it with a duplicate of the site.
    I’ll tell you what happened…

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    ๐Ÿณ๏ธโ€๐ŸŒˆ Plugin Review Team Rep

    It’s a shared hosting.

    That’s a bad idea. Multisite doesn’t play great on Shared. SSL plays even worse.

    That explains a lot of issues. I will get a VPS!!!

    The redirection was caused by MT’s shared hosting: Grid Service.
    We moved to a VPS with another hosting company and the random redirection stopped instantly.
    Thanks for your help.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘backend http to https random redirection’ is closed to new replies.