WordPress.org

Support

Support » How-To and Troubleshooting » back ups are not finishing

back ups are not finishing

  • I’m trying to back up my database so I can upgrade to 3.1.4, but the backup option keeps stopping somewhere around 2% to 8% complete. It doesn’t give me an error. It simply stops updating the screen and never finishes.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Christine Rondeau

    @crondeau

    Volunteer Forum Moderator

    What are you using to do your backup? Perhaps the plugin is being flaky?

    I use wp db backup – http://wordpress.org/extend/plugins/wp-db-backup/ and it works perfectly.

    If it’s a different issue, you could also access you PhpMYadmin and get the back up that way.

    I’m just using that very plugin. I’ve tried the recommended remedy on the author’s site and it doesn’t help.

    Christine Rondeau

    @crondeau

    Volunteer Forum Moderator

    do you have access to phpMyadmin?

    Maybe go in there and do a back up that way.

    Perhaps your db is too big too.. maybe delete the post revisions?

    I can do that, but this is easier and worked up until very recently. When I upgrade to 3.1.3 it was fine.

    Try displaying errors, if there is a bug and you find something quick for the community it could help a lot…

    global $wpdb;
    ini_set(‘display_errors’,1);
    error_reporting(E_ALL);
    $wpdb->show_errors();

    Put that in the plugin main file or config file.

    If you get no errors, then maybe it is still running in a loop, does the browser show processing activity?

    Oh and that error display code will display errors for entire blog. I give it to customers and they always think I broke their blog or my plugins that use this code has done even through the errors point to other plugin files lol

    I don’t see any errors messages at all. WordPress just stops hitting the server and refreshing in the middle of the backup.

    I went back to the remedy from the plugin website and I increased the delay time. The backup is now slow, but it works.

    I don’t consider this fixed, but at least I have a workaround.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘back ups are not finishing’ is closed to new replies.
Skip to toolbar