Support » How-To and Troubleshooting » Back To Site Link Missing

Back To Site Link Missing

  • There used to be a ‘back to site’ link top left when in the admin panel. Now it’s gone with version 3. Bring it back! Please :o)

Viewing 9 replies - 1 through 9 (of 9 total)
  • esmi


    Forum Moderator

    It’s still there. Try clicking on the site’s name in the top left-hand corner of the dashboard.

    The name snot there for me, only the round WordPress logo which isn’t live.

    If the Settings>Site Title box is blank then there is no name in the top left corner, and that is when it is missing. Tried on 4 themes



    Forum Moderator

    The site title box shouldn’t be blank. If you need to hide the site’s title on the public site, use CSS.


    Thinking on…
    still a glitz. It didn’t NOT work in versions up to 3.0, why does it not work now?
    Lots of users of WP don’t want the name there, but don’t want to change the CSS, or might hide it with white text, incurring a hidden text Google penalty..
    Needs fixing in my POV.



    Forum Janitor

    The link is there, but if you have a blank site title then the link will just be a single space, so it’s quite small, and invisible.

    I’ve raised a suggested enhancement to get this altered.


    <span id="site-title"><?php echo $blog_name ?> </span>

    in admin-header.php in /wp-admin/

    and add this after it,

    <a href="<?php echo home_url( '/' ); ?>">visit site</a>

    Thanks, I’d been looking for an answer for two days, this topic had never showed up in my WP search inquiries, but today it did show up with another search (after my new “new topic” post failed to show up).

    I filled in the Site Title box and the site name magically showed up on the admin panel header.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Back To Site Link Missing’ is closed to new replies.