Support » Plugin: BackWPup - WordPress Backup Plugin » AWS S3 backup – Region setting and bucket not existing error

  • I found this other support topic that did not really have an answer.

    https://wordpress.org/support/topic/cannot-backup-to-amazon-s3/

    This person was experiencing the same error I was. And for quite a while, I could not figure out why because :
    a. I put in my proper Access Key credentials
    b. I was able to see ALL my S3 buckets in the drop-down list, and selected the one I had access to
    c. Backup failed with same error -> does not exist

    Just like her/him.

    I found out that even though I can see my buckets listed in the drop down after I entered my correct Access Key credentials, my REGION SELECTION in my job settings was wrong.

    That kept causing my backups to fail with the same error <bucketname> does not exist.

    Once I selected the correct region, then backup went fine.

    Why does BackWPup show the selection of the S3 buckets if the region is wrong?

    It seems wrong that the configuration of a job SEES the bucket.
    But the execution of the job gives -> <bucketname> does not exist.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support duongcuong96

    (@duongcuong96)

    Hi @victorkun
    Which BackWPUP version did you get the issue?
    Thanks!

    Sorry…my INBOX did not show that you replied to my post, so just saw this today. We are in the process of upgrading our 80+ sites…but on this one we are at BackWPup version 3.6.0.

    When I want to backup to S3, I go to the “To: S3 Service” tab.
    I see a dropdown selection for “Select a S3 service” which said “Amazon S3: US Standard”….I thought this sounded correct, so I skipped it. I did not realize this is actually the AWS Region selection.

    Then there’s a field for “Or a S3 Server URL”…which we leave blank.

    Then there’s the Multipart Upload checkbox.

    Then there are the Access and Secret Key fields, which I fill out properly.

    Then I can select my S3 bucket. And I can see all my S3 buckets in the drop down, so I select the proper one….

    I save.

    I run the backup and then I got that error.

    Later I realized I had to select
    NOT -> Amazon S3: US Standard
    But rather -> Amazon S3 : US West (Oregon)

    So it seems odd that my backup config can see and select my bucket when keys are correctly set…

    But then on job execution, it says it can’t find my bucket.
    (found out later it’s cuz the “Select a S3 Service” was wrong…)

    Maybe this field should be renamed “Select AWS Region”…or maybe not even be there at all since the keys seem to locate the bucket….???

    Well, I figured out how to make it work anyways, and I haven’t seen the newer versions of this plugin…maybe this is fixed…

    Love the plugin though…just thought I’d share this experience.

    • This reply was modified 6 months, 2 weeks ago by victorkun.
    Plugin Support duongcuong96

    (@duongcuong96)

    Hi @victorkun
    There is some issue with BackWPUp 3.6.10 and custom S3 url and will be fixed soon in the future update.
    Will inform you about that 🙂
    Thank you for sharing your experience ^^

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘AWS S3 backup – Region setting and bucket not existing error’ is closed to new replies.