Support » Plugin: BackWPup - WordPress Backup Plugin » AWS S3 Backup Error (ver 3.4.3)

  • backwpup.3.4.2 -> backwpup.3.4.3
    S3 Backup Error

    in Dashboard Select Backet
    “The authorization header is malformed; the region ‘ap-northeast-1’ is wrong; expecting ‘us-east-1′”

    If you return the version “3.4.2” i can back up normally

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support duongcuong96

    (@duongcuong96)

    Hi, @next-season,
    Could you please tell me what S3 backup destination do you select?

    Hi, @duongcuong96

    Thank you for your reply.
    ex:
    http://docs.aws.amazon.com/IAM/latest/UserGuide/reference_policies_variables.html

    When Use Such a setting

    Bucket selection : backup-bucket
    Folder in bucket : aws:username

    ==== IAM USER Policy ====

    
    {
        "Version": "2012-10-17",
        "Statement": [
            {
                "Action": [
                    "s3:ListAllMyBuckets",
                    "s3:GetBucketLocation"
                ],
                "Effect": "Allow",
                "Resource": [
                    "arn:aws:s3:::*"
                ]
            },
            {
                "Action": [
                    "s3:ListBucket"
                ],
                "Effect": "Allow",
                "Resource": [
                    "arn:aws:s3:::backup-bucket"
                ],
                "Condition": {
                    "StringLike": {
                        "s3:prefix": [
                            "${aws:username}/*"
                        ]
                    }
                }
            },
            {
                "Action": [
                    "s3:*"
                ],
                "Effect": "Allow",
                "Resource": [
                    "arn:aws:s3:::backup-bucket/${aws:username}",
                    "arn:aws:s3:::backup-bucket/${aws:username}/*"
                ]
            }
        ]
    }
    

    ====

    There was no problem with BacWPup Version 3.4.2
    I would highly appreciate if you Check.
    Thank you

    • This reply was modified 1 year, 7 months ago by  NExT-Season.
    Plugin Support duongcuong96

    (@duongcuong96)

    @next-season,
    thank you! I will check it and get back to you soon 🙂

    Plugin Support duongcuong96

    (@duongcuong96)

    @next-season
    Hi, for the new version 3.4.4, is your issue got resolved?
    thanks!

    @duongcuong96
    I update&checked version 3.4.4,

    If you use a region other than us-1 it seems that an error occurs in authentication
    .

    “The authorization header is malformed; the region ‘ap-northeast-1’ is wrong; expecting ‘us-east-1′”

    Thank you

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘AWS S3 Backup Error (ver 3.4.3)’ is closed to new replies.