Support » Plugin: Amazon Associates Link Builder » AWS.InvalidParameterValue error

  • Hi,
    after the update to the most recent version (1.9.1) I keep getting thousand of

    <h4>AWS.InvalidParameterValue</h4>

    errors as long as

    Item_Lookup_Response_Cache_Loader :: create_cache_entry::<h4>AWS.InvalidParameterValue</h4>

    Using the previous version (1.8.0) I did not received these kind of errors.

    Could you please help?

    Best regards,

    Nicola

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • taisa1984

    (@taisa1984)

    Hi! Where do you see this errors? I am looking for a log or something and don’t find it.

    Also, better update to the latest version because it fix a important issue.

    nicolaottomano

    (@nicolaottomano)

    You can see it into the php-errors.log if you enable the following in wp-config.php

    ini_set('log_errors', 'On');
    ini_set('error_log', '/website path/www.mywebsite.com/home/wp-content/log/php-errors.log');
    error_reporting(E_ERROR | E_WARNING | E_PARSE);

    Nicola

    taisa1984

    (@taisa1984)

    Hi! Thanks to you I was able to start tracking this too. Today I had more than 10.000 errors, and 8.000 of them where about cache_loader. I had only 400 page views today by this time. And only have around 125 posts with links to amazon (some of them even not with the API at all).

    Do you know maybe a way to track which URL is causing the error? Maybe that would help a lot, but didn’t find a way to do that. Maybe they could add this kind of information within the errors, which link and which url created the error.

    I started yesterday removing links or changing so they don’t use the API to check and try to still get some sales, and it is not getting any better.

    If you find something more, let us know! Thanks!

    nicolaottomano

    (@nicolaottomano)

    I hope that @amazonlinkbuilder could give us more details on this error.

    Nicola

    Plugin Author Amazon Associates Link Builder

    (@amazonlinkbuilder)

    Dear @nicolaottomano,

    This issue is thrown by cron job which updates the cache. This issue can occur if any of the tracking id configured for a marketplace in past has been deleted later from the setting page of the plugin, but the tracking id is still present in some of your post.

    Please configure your tracking ids correctly on your setting page of plugin.

    Dear @amazonlinkbuilder
    I have hundreds of posts on my blog, is there a way to know which pages are throwing this error?

    Best regards

    Nicola

    Since the support and the development of this pulgin is really bad, I managed to solve the issue by myself.

    If you want to get rid of the literally thousands of error logs, you can edit the /wp-content/plugins/amazon-associates-link-builder/cache/item_lookup_response_cache_loader.php file at row 140 this way:

    if (strpos($this->paapi_helper->get_error_message( $e->getMessage() ), 'InvalidParameterValue') !== true) {
    				//Stopping the InvalidParameterValue errors by saturating the PHP errors log. Let pass only the others.
    				error_log( 'Item_Lookup_Response_Cache_Loader :: create_cache_entry::' . $this->paapi_helper->get_error_message( $e->getMessage() ) . implode(" ",$asins_array) );
    			}

    As you can see, I added the . implode(” “,$asins_array) istruction in order to get the list of ASINs causing the errors.

    Hope it helps to all people experiencing this issue.

    Nicola

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘AWS.InvalidParameterValue error’ is closed to new replies.