Support » Plugin: Google Website Translator » Awesome!

  • Panicked today when my website shows only the shortcode for Google Translate, not the language selector. Apparently Mother Google, bitch that she can be, just decided to eliminate free access to the Translator. Typical arrogant, stupid move by Google. Every site that I went to about installing the widget is now out of date because all you get is the cryptic message from Google that it’s no longer available.

    I finally found this wonderful plugin, downloaded and installed it, selected Spanish and added the shortcode to my site. Works perfectly! Thank you! Thank you!

Viewing 4 replies - 1 through 4 (of 4 total)
  • ChecMark

    (@checmark)

    Panic now! I wanted to see if the plugin was translating other pages. Clicked on Spanish on my homepage and now can’t get English back! PLEASE HELP!

    Assuming I figure out how to get my homepage back to English how do I get other pages to translate? Not all pages have somewhere to add the widget, unless maybe I put it in the footer. Suggestions?

    Plugin Author Prisna

    (@prisna)

    Greetings,

    please send at least one link where the issue you’re facing can be seen.

    Regards

    ChecMark

    (@checmark)

    Although in the options I set that the site is in English and then added Spanish, I could not figure out how to get back to English. I went back into the options and added British English and was then able to go back to English, but that didn’t seem right.

    I then tried to add the translation into the page footer so that it would be on every page but it did not work as a footer widget. I then added the widget to several sidebars and it works there.

    My site is https://ajijictoday.com.mx/

    Appreciate any help.

    Plugin Author Prisna

    (@prisna)

    Thanks for the explanations and link.

    1) To restore back to the original language you should not hide the Translation banner in:

    Advanced > General > Other customizations > Translation banner

    Or as you said, you can add English to the available languages. This is is how Google built the translator.

    2) I’m checking your site and I do see other widgets in the footer, so most likely the theme is working fine and it’s rendering the widgets in the footer area. But you can only have one translation widget per page. So if you have it in two places, it’ll show up in only one. Please verify you’re adding the widget in the footer, and in the footer only.

    Regards

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Awesome!’ is closed to new replies.