Support » Plugins and Hacks » aweber-integration plugin – aweber account id

  • Following the instructions for the aweber-integration plugin to locate my Aweber account id does not work. There is no settings option displayed on the Reports tab in aweber. I chatted online with aweber support and they don’t seem to know what an account id is.

    What value am I supposed to enter in the plugin settings page for aweber account id?

Viewing 13 replies - 1 through 13 (of 13 total)
  • try 49, and hope for the best!

    Hi jdbaok,

    It seems like Aweber has changed their interface without updating their documentation.

    I have just logged into our Aweber account, and I’ve been unable to find the screen that lists the account id.

    I have contacted Aweber, and will update this thread once they tell me how to get the AWeber Email Web analytics Account ID.

    James

    Hi jdbaok,

    Here is the response from AWeber support:

    The Settings menu is available for those who are on the Analytics package. It is possible that the account is still on the old package, which doesn’t have that option. Installing Web Analytics like article #523 refers to is only available for those who have the Analytics package.

    They can simply contact us by email or phone to request an upgrade. They will need to confirm their login and password to do so.

    So if you don’t have the Reports -> Settings menu option, you will need to contact AWeber to have your account upgraded to the new package that includes analytics.

    I will update the plugin explaining this too.

    James

    AprilBraswell

    (@aprilbraswell)

    In the setting it up at in widgets dashboard section,

    Unit: (letters, numbers and hyphens only)
    For example, your unit is the word in bold in the following example: <input type=”hidden” name=”unit” value=”default537640“>

    totally not seeing anything LIKE that in the raw html of my aweber form set up.

    help

    James Collins

    (@jamescollins)

    Hi April,

    It looks like the AWeber interface has changed. To find the unit:

    1. Click on the Web Forms menu
    2. Click on the Get HTML option that corresponds to the form you are trying to add.
    3. Click on “Raw HTML Version”.
    4. The required variables will be shown in the HTML code.

    I will update the plugin with more accurate instructions too.

    James

    Version 1.1 of the plugin has now been released.

    It contains more detailed instructions on how to find your aweber account id.

    Hi James,
    I installed the plugin, put in the required “unit” and “form id” variables but nothing showed on my blog page.

    I then tried something to get it to show. I discovered that the “” marks must be removed from the form on WordPress widgets for it to work properly. Learned something new today LOL!

    I am a complete newbie to all of this. I am sending this along because other newbies might find it helpful.

    Thanks for your help here on the forum,
    Doug

    Hi Doug,

    Thanks for the comments. I have just made some minor changes to the widget configuration screen to help make this more obvious.

    The changes will be released in the next version.

    James

    You guys might also want to check out http://feedmailpro.com as a cheaper alternative to Aweber for blogs specifically.

    @jamescollins
    Still not seeing the “unit” etal items in the raw html. What am I missing?

    @gvwriter, AWeber has changed the formatting of the embed code, and they now display the JavaScript Snippet version by default.

    You need to look at the “RAW HTML Version” rather than the “JavaScript Snippet”.

    We have plans to improve the plugin so it supports the JavaScript snippet, but for now only the HTML version is supported.

    I’ve set the plugin up fine, but doing a test subscribe I get an aweber error message that says:

    Your form submission was successful but the website owner of the previous page did not provide a valid redirect (“Thank You”) page. The URL provided does not follow proper web standard formats. You may wish to notify that website owner by pushing the “back” button on your web browser.

    Have tried leaving tha thnk you page option blank and also tried adding a page- makes no difference same error message, double checked and all is set up correctly in aweber so I’m lost on this, can anyone advise please?
    Thanks

    @tiameg,

    That problem also a symptom of AWeber updating their tracking code (and the plugin needing to be updated accordingly)

    We do have plans to fix this problem in the next version of the plugin – I will update this thread once we have done so.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘aweber-integration plugin – aweber account id’ is closed to new replies.