Support » Fixing WordPress » Aweber API problem, plus "Unexplained Error" message, can't search plugins

  • Resolved AnnieSisk


    Running 3.5.1 on … yesterday I installed and activated three new plugins – Title Split Testing, WordFence, and Pinterest Image Pin. Immediately after doing so without incident, I noticed a warning message that I needed to reauthorize the AWeber plugin – a process that consists of a click, copy of a verification code, paste back into settings and save. Did this several times but kept getting another error message (“unable” to connect with the API – I’m paraphrasing).

    I deactivated then deleted the AWeber plugin. I then searched for it to upload it again but got the following:

    “An unexpected error occurred. Something may be wrong with or this serverโ€™s configuration. If you continue to have problems, please try the support forums.”

    I deactivated all the plugins I installed yesterday, and tried again with the AWeber plugin. No changes.

    I’ve searched through some of the past threads on this issue and they don’t seem to apply to me – I’m not behind a corporate firewall, I’m not running anything but vanilla self-hosted WP 3.5.1., etc. I’ve done a Sucuri scan – no signs of malware or hacks.

    It’s ironically not an immediate problem – I haven’t been using the AWeber plugin, and can get by with the coded form in the sidebar widget. But it makes me wonder what else is going on, and whether this might have some other unfortunate consequence.


Viewing 8 replies - 1 through 8 (of 8 total)
  • Addendum: there’s one other thing that’s been screwy on this site for awhile. I get an “update” icon in the plugins menu but none of them need updating. If you click “updates” in the Dashboard, nothing’s listed – everything’s up to date, but it still shows that “1” icon next to the words “Updates” and “Plugins.” That’s been going on for months – it didn’t seem to affect any functionality so I’ve just ignored it – no clue if it’s related to this or not.

    Plugins can conflict with each other – so you may not be able to use all those together. But for specific plugin questions, please post in the plugin specific forum – on the plugin’s page – click on the Support Tab – then scroll down and make a new post which will be tagged with the plugin name.

    I appreciate the reply. But I already tried deactivating each – I still got the same error message on a plugin search. I don’t think it’s a plugin problem.

    Have you tried deactivating all your plugins and resetting the plugins folder –

    Also try switching to the default theme with no plugins active.

    That can sometimes clear up an odd issue.

    Hey – I did try deactivating them all manually but didn’t try resetting the plugins folder. Will do that next. Thanks – will report back tomorrow with results. Mods, please do not lock this thread until I post then! ๐Ÿ™‚

    We don’t lock or close threads unless there is a compelling reason to – none here at all.

    It’s apparently been an issue with some folks (i.e., past threads I found when I searched for other guidance on this issue) – just wanted to make sure, better safe than, etc.. ๐Ÿ™‚ No offense intended.

    Resolved. It was a conflict between two of the new plugins, rather than one of the plugins itself – required much comparison and trial and error. Somebody needs to develop a plugin for that. ๐Ÿ˜‰

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Aweber API problem, plus "Unexplained Error" message, can't search plugins’ is closed to new replies.