Support » Themes and Templates » Awake theme broken after hosting migration

  • Hello!

    I migrated a wordpress website from Network Solutions to GoDaddy last night. All worked perfectly except some parts of the Awake theme.

    The homepage image slider is only bringing in 3 of the 7 images and the thumbnails for the slider are not being pulled in at all. There is also a recent news sidebar that is part of Awake that has thumbnails that are not being pulled in.

    It is very strange. The image slider has all the images in place with absolute paths but still only 3 of the 7 images are being pulled into the slider. I’ve racked my brain endlessly and cannot see what the issue is.

    Here’s a link to the testing server where I am working on the website. You will see the issues I’m talking about there…

    I really need to get this up and running today. Any and all help is greatly appreciated.

    Thanks in advance!

Viewing 8 replies - 1 through 8 (of 8 total)
  • FYI…

    Some things I’ve tried already…

    1. Reinstalling the theme. I’ve doen this 3 times now.
    2. Setting permissions to 777 on the timthumbs.php file as well as the cache folder
    3. I’ve deleted the images it won’t pull in and re-uploaded them again to the media library and tried to enter them into the Awake theme slider interface.

    All have failed to do anything to fix the problem.

    Hmmmm…thoughts? 🙂

    Another thing that happens…

    On the first slide I have the image set to ‘full’. If I keep the image that I have in there and set it to ‘partial staged’ it still won’t pull the image in. If I take one of the images that IS WORKING (one of the 3 that are working) and put it in the first slide it works AS LONG AS the setting is put to ‘partial staged’. But if its set to ‘full’ it won’t work.

    All the paths are correct. They are absolute to the upload folder. I see the images in the media library. They are there.

    It seems like something is going with the Awake theme. Could it be a version issue? I kept the exact same version of WordPress in place when I did the migration. So nothing should be different from the old host.

    I took a look at the images, they are in fact in the correct location and they don’t give me 404 errors. However, I think the problem is with timthumb. TimThumb is the script that re-sizes the images so that they fit nicely in their correct location as thumbnails. When I try to use the script through this url, this is what I get:

    A TimThumb error has occured
    The following error(s) occured:
    You may not fetch images from that site. To enable this site in timthumb, you can either add it to $ALLOWED_SITES and set ALLOW_EXTERNAL=true. Or you can set ALLOW_ALL_EXTERNAL_SITES=true, depending on your security needs.

    I think the problem is that you can’t use external images in TimThumb unless you enable them. I don’t know how you would do that, but I think that if you can find a way to enable the external sites, then your problem will be fixed. Good luck, please let me know if you figure this out.

    I did a quick google search and found this. It’s a tutorial on how to add external sites to TimThumbs.

    I’ll have a look at this. Thanks!

    The thing is, I don’t think that any of the images are external images. All are hosted in the WordPress media library and reside on the testing server domain. Everything is set to an absolute path to the WordPress upload folder.

    Yeah I also noticed that. But for some reason TimThumb still gives an error even though there are no actual external images, because they are all hosted on wp-content on the same domain. Try the link I sent you, maybe it will fix it.

    Thank you Ziv! It worked! I had to add the testing server domain to the thumbs.php allowable list. Honestly, I bet if when I pull it off of testing it will work fine without the allowed list being modified. The testing is a subdomain therefore seems to cause trouble.

    You rock!


    Hi Ziv!

    So this issue has reared its ugly head once again. This time after transferring my nameservers and moving away from the testing server. TimThumb won’t load any images now. Everything is hosted on the root domain now so it seems it should be fine but no dice. It doesn’t have to pull remote images now. I don’t get it… 😛

    Here’s the path to TimThumb (thumb.php)…

    I get the following error…

    A TimThumb error has occured
    The following error(s) occured:
    No image specified
    Query String :
    TimThumb version : 2.8.2

    Any thoughts? I’m stumped…

    Thanks in advance!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Awake theme broken after hosting migration’ is closed to new replies.