Support » Theme: GeneratePress » Avoid Non-Composited Animations

  • John

    (@allonlinetools)


    I am using your theme. But recently I noticed that I am facing a CLS problem on PageSpeed Insights.
    PageSpeed Insights show the error *avoid non-composited animations* and the warning message is *Unsupported CSS Property: color* and *Unsupported CSS Property: background-color*
    Every single post has more than 40+ error!!
    How can I solve this problem.
    Thanks in advance.

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • David

    (@diggeddy)

    Hi there,

    first issue is the lazyloading of the logo. In your lazy loader, they generally have an option to exclude lazy loading using a CSS class – you can use: is-logo-image

    The other CLS issues are related to your post content – the major one is the Table of Contents – on initial load the ToC is open and after load the JS/CSS closes it. You would need to speak to the ToC plugin developer regarding that issue.

    Thread Starter John

    (@allonlinetools)

    Sorry for my late reply.

    I have disable Table of contents plus plugin.
    And added this css class on Litespeed cache plugin exclude section.

    Then cleared the caches and checked it.
    But still same problem šŸ˜Œ.

    David

    (@diggeddy)

    I am getting a ERROR 520 reported when i try visiting the link now ?

    Thread Starter John

    (@allonlinetools)

    Yesterday my hosting server was down. Please now check it.

    Elvin

    (@ejcabquina)

    Can you test the page again with this CSS added?

    input#XLEW_1_6_2 {
        transition: unset !important;
    }

    Let us know how it goes.

    Thread Starter John

    (@allonlinetools)

    ejcabquina I have added the CSS but still same problem.

    Theme Author Tom

    (@edge22)

    I’m not seeing the issues that were originally reported here.

    My test is showing a CLS of 0.093, which is being caused by these elements: https://www.screencast.com/t/hrVNALfV3y

    Thread Starter John

    (@allonlinetools)

    Most of the it doesn’t show the error.
    But if you try 2-3 times it will show you these errors.

    Theme Author Tom

    (@edge22)

    Can you deactivate LiteSpeed Cache to see if it’s contributing to the issue? I’m seeing a slight flash of unstyled text as the site loads, which is usually caused by the CSS being loaded too late.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Avoid Non-Composited Animations’ is closed to new replies.