Support » Plugins and Hacks » AVH Extended Categories Widgets 3.2 Fatal error

  • Resolved CallUp

    (@callup)


    I just upgraded successfully to 3.2, but when I tried to activate it read:

    Plugin could not be activated because it triggered a fatal error.

    Warning: require_once() [function.require-once]: Unable to access /home1/alterpol/public_html/wp-content/plugins/extended-categories-widget/2.8/helpers/avh-forms.php in /home1/alterpol/public_html/wp-content/plugins/extended-categories-widget/2.8/avh-ec.client.php on line 45

    http://wordpress.org/extend/plugins/extended-categories-widget/

Viewing 8 replies - 1 through 8 (of 8 total)
  • Ditto for me.

    Version 3.2.0.1 should resolve this issue.
    My apologies people.

    Thanks Peter. 3.2.0.1 fixed it.

    mpmchugh

    (@mpmchugh)

    Just had a client’s site totally break due to an error in 3.2.1. Tried removing and reinstalling the latest and get the same thing:

    Fatal error: Cannot use object of type WP_Error as array in /home/compute/public_html/wordpress/wp-content/plugins/extended-categories-widget/2.8/class/avh-ec.category-group.php on line 134

    Is this a new problem, or some known incompatibility? Site’s running WP 2.9.2

    Thanks,
    Michael

    petervanderdoes

    (@petervanderdoes)

    Michael,

    What version of AVH Extended Categories Widgets are you running right now?

    Looking at the code and WordPress code, if there was a problem I would be expecting the error to come one line earlier.

    mpmchugh

    (@mpmchugh)

    Thanks for the reply, it seems the error is being thrown because all the Categories and Tags in the system somehow disappeared. I’m having the host to a database restore now. Have you ever checked how your plugin reacts to the lack of categories? It seems to throw that error in such a case.

    -mpm

    petervanderdoes

    (@petervanderdoes)

    There is the assumption there are categories. It’s a good point, I should add this check in as well.

    Good luck on your restore.

    We had this problem too, on a Multisite installation (using 3.0.4). It was fixed by fixing another problem, where the categories and tags do not save. See the following thread for info on the latter:

    http://mu.wordpress.org/forums/topic/18403

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘AVH Extended Categories Widgets 3.2 Fatal error’ is closed to new replies.