Support » Plugin: Avatar Privacy » Avatars not loaded from Gravatar

  • Resolved jenskoegler

    (@jenskoegler)


    Yes, that would have been very helpful to know how the issue was fixed. I’ve got the same problem.

    When I activate the plugin all avatars in the comments are replaced by the Standard-Avatar I’ve chosen in WP -> Settings -> Discussion. Even my own avatar is gone and replaced by it.

    When I log out of my backend and write a test-comment, still the standard avatar is shown (even when I tick the box that I want to use my gravatar). It seems that the plugin doesn’t load an avatar from Gravatar at all, even when I’ve agreed to do it.

    When I deactivate the plugin, all gravatars are back in the comments (mine included).

    Jay

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author pepe

    (@pputzer)

    The test comment, has it been created by your user (i.e. while you were logged in), or “anonymously” via entering name and mail address in the comment field?

    Thread Starter jenskoegler

    (@jenskoegler)

    Anonymously. I was logged out completely. I’ve also ticked the box that avatars can be used but the avatar didn’t show up.

    I’ve activated the plugin again and posted a test comment. Here is the link to the wp page.
    https://www.buecher-wie-sterne.de/corona-virus-leipziger-buchmesse-2020-abgesagt

    • This reply was modified 12 months ago by jenskoegler.
    Plugin Author pepe

    (@pputzer)

    OK. That’s by design, so that someone else can’t impersonate registered users. If an email is associated with a user account, only the setting in the user’s profile (Gravatars) is relevant for the display of Gravatars. There is another setting in the profile (Logged-out Commenting) that allows anonymous comments to use that user’s avatar (including the Gravatar).

    Thread Starter jenskoegler

    (@jenskoegler)

    The plugin even changes my WP avatar in the top right corner of my WP dashport.
    Where can I change logged-out commenting? Couldn’t find it in my gravatar profile.

    I don’t want to activate anonymous comments with gravatar.
    The gravatar icon doesn’t even show up when I am logged in WP. It only does when I upload an avatar for me on my server.

    Plugin Author pepe

    (@pputzer)

    Yes, the plugin changes all uses of avatars on front- and backend to prevent data leakage. The setting is in the WordPress user profile section “Profile Picture”.

    Thread Starter jenskoegler

    (@jenskoegler)

    It’s working now. There was a tick missing in my WordPress Profile to allow my Gravatar to be loaded. This necessary tick should be mentioned somewhere because the Gravatars worked fine before the plugin was activated.

    Thread Starter jenskoegler

    (@jenskoegler)

    But it doesn’t change the little gravatars next to the “Like”-Button.
    Will the plugin change back the gravatars from the past comments when somebody posts a new comment and accepts gravatars to be loaded?
    All the gravatars from past comments are gone now which doesn’t look very nice.

    Plugin Author pepe

    (@pputzer)

    Yes, when someone updates their Gravatar setting, it applies to all previous comments. You can also change the default (for comments made before Avatar Privacy was installed) by enabling Display Gravatar images by default in the Avatar Privay section of the Discussions settings page.

    Not sure what you mean by “little gravatars next to the ‘Like’-Button” – is that perhaps a Jetpack feature?

    Thread Starter jenskoegler

    (@jenskoegler)

    Thanks for the support.
    Yes, it is probably a Jetback feature but it shows the Gravatar images. You can see them next to the “Liken”-Button at the end of the posts but above the comments.
    https://www.buecher-wie-sterne.de/corona-virus-leipziger-buchmesse-2020-abgesagt/

    Plugin Author pepe

    (@pputzer)

    Thanks for the link, @jenskoegler. Yes, that’s a Jetpack thing. The problem with various Jetpack modules is that the HTML markup is generated on the WP.com servers where my plugin is of course not activated.

    IF you are concerned about your visitor’s privacy, I’d suggest turning those modules off. Technically, it is very similar to having a FB social widget embedded in your page.

    Thread Starter jenskoegler

    (@jenskoegler)

    Thanks a lot. I think it’s OK. It can easily be turned off.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Avatars not loaded from Gravatar’ is closed to new replies.